Project

General

Profile

Feature #18010

UI Notifications front-end implementation

Added by Gail Steiger over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Notifications
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

patternfly front-end for rails back-end fixes #16736 - UI Notifications support rails part #3902


Related issues

Related to Foreman - Bug #18191: notification should not keep initiating new pull requests when there is an active requestClosed2017-01-22
Related to Foreman - Tracker #16736: Add UI Notification supportNew2016-09-29

Related to Foreman - Bug #18192: notification should not keep fetching events when timeout occuredClosed2017-01-22
Related to Foreman - Bug #18193: When there are no notification events, the notification drawer should mention itClosed2017-01-22
Related to Foreman - Bug #18194: notification expand toggle should not be usedClosed2017-01-22
Related to Foreman - Bug #18234: notification icon is incorrect when having no notificationsClosed2017-01-25
Related to Foreman - Bug #18248: dashboard auto refresh causes notification component to duplicate it selfClosed2017-01-26
Is duplicate of Foreman - Feature #17547: UI implementation of notification drawerDuplicate2016-12-01

Associated revisions

Revision 1c40f7e8 (diff)
Added by Gail Steiger over 4 years ago

fixes #18010 - UI Notifications front-end implementation

Revision 2faa7745 (diff)
Added by Dominic Cleal over 4 years ago

refs #18010 - require moment

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4170 added

#2 Updated by Gail Steiger over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal over 4 years ago

  • Category set to Notifications
  • Legacy Backlogs Release (now unused) set to 209

#4 Updated by Ohad Levy over 4 years ago

  • Related to Bug #18191: notification should not keep initiating new pull requests when there is an active request added

#5 Updated by Ohad Levy over 4 years ago

  • Is duplicate of Feature #17547: UI implementation of notification drawer added

#6 Updated by Ohad Levy over 4 years ago

#7 Updated by Ohad Levy over 4 years ago

  • Related to Bug #18192: notification should not keep fetching events when timeout occured added

#8 Updated by Ohad Levy over 4 years ago

  • Related to Bug #18193: When there are no notification events, the notification drawer should mention it added

#9 Updated by Ohad Levy over 4 years ago

  • Related to Bug #18194: notification expand toggle should not be used added

#10 Updated by Daniel Lobato Garcia over 4 years ago

  • Target version set to 169

#11 Updated by Liza Gilman over 4 years ago

  • Related to Bug #18234: notification icon is incorrect when having no notifications added

#12 Updated by Ohad Levy over 4 years ago

  • Related to Bug #18248: dashboard auto refresh causes notification component to duplicate it self added

#13 Updated by Brad Buckingham over 4 years ago

  • Target version deleted (169)

#14 Updated by Daniel Lobato Garcia over 4 years ago

  • Target version set to 1.11.0

Also available in: Atom PDF