Project

General

Profile

Bug #18019

Sync Plans UI: Unable to create one.

Added by Brad Buckingham over 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Unable to create a sync plan in the UI.

- go to : Content > Sync Plans
click 'New Sync Plan'

- enter name & interval
- enter tart date (e.g. 2017-01-31) (Note: unable to get the 'calendar' to select one)
- click 'Save'

Error observed in console:

angular.self.js?body=1:13551 TypeError: syncPlan.startDate.getTimezoneOffset is not a function
at Scope.$scope.createSyncPlan (https://centos7-devel/assets/bastion_katello/sync-plans/new/new-sync-plan.controller.self.js?body=1:45:66)
at fn (eval at compile (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:1:0), <anonymous>:4:312)
at Scope.destination.(anonymous function) [as handleSave] (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:9818:22)
at fn (eval at compile (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:1:0), <anonymous>:4:221)
at Scope.destination.(anonymous function) [as handleSave] (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:9818:22)
at fn (eval at compile (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:1:0), <anonymous>:4:253)
at expensiveCheckFn (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:15486:18)
at callback (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:25019:17)
at Scope.$eval (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:17230:28)
at Scope.$apply (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:17330:25)

History

#1 Updated by Walden Raines over 4 years ago

  • Assignee set to Walden Raines
  • Target version set to 154

#2 Updated by Walden Raines over 4 years ago

  • Status changed from New to Need more information

Brad Buckingham wrote:

Unable to create a sync plan in the UI.

- go to : Content > Sync Plans
click 'New Sync Plan'

- enter name & interval
- enter tart date (e.g. 2017-01-31) (Note: unable to get the 'calendar' to select one)
- click 'Save'

Error observed in console:

angular.self.js?body=1:13551 TypeError: syncPlan.startDate.getTimezoneOffset is not a function
at Scope.$scope.createSyncPlan (https://centos7-devel/assets/bastion_katello/sync-plans/new/new-sync-plan.controller.self.js?body=1:45:66)
at fn (eval at compile (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:1:0), <anonymous>:4:312)
at Scope.destination.(anonymous function) [as handleSave] (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:9818:22)
at fn (eval at compile (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:1:0), <anonymous>:4:221)
at Scope.destination.(anonymous function) [as handleSave] (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:9818:22)
at fn (eval at compile (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:1:0), <anonymous>:4:253)
at expensiveCheckFn (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:15486:18)
at callback (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:25019:17)
at Scope.$eval (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:17230:28)
at Scope.$apply (https://centos7-devel/assets/bastion/angular/angular.self.js?body=1:17330:25)

I cannot reproduce this given the steps in the summary.

Note, in order to get the calendar you click on the calendar button.

#3 Updated by Walden Raines over 4 years ago

  • Status changed from Need more information to Closed

After speaking with Brad we determined this was a local issue.

#4 Updated by Brad Buckingham over 4 years ago

If a user hits this, be sure to clear the browser cache (shift-reload) and try again.

Also available in: Atom PDF