Project

General

Profile

Actions

Feature #18064

closed

Ability to import and provision existing VMs

Added by Timo Goebel over 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

It should be possible to create new hosts by importing an existing VM into Foreman. It could be done similar to the clone action of a host, but triggered from the VM listing in the compute resources show page. The attributes provided by the compute resource should be imported.

The use case is, that you might not be able to create your VM through Foreman (because of internal policies, special configuration needs, ...) but still want to use Foreman to install the VM.


Related issues 10 (1 open9 closed)

Related to Foreman - Bug #19252: Associating VM fails with unknown permission for compute_resources_vms#associateClosedTomer Brisker04/12/2017Actions
Related to Discovery - Bug #19414: Discovery host form errors out with Please try to update your requestClosedTomer Brisker04/27/2017Actions
Related to Foreman - Bug #19419: Invalid syntax in aws fog extensionClosedBen Plessinger04/27/2017Actions
Related to Foreman - Bug #19436: dropdowns on discovered host do not workClosedTomer Brisker05/03/2017Actions
Related to Xen - Bug #19566: Creating a new host VM on xen fails with: undefined method `new_host?' Closed05/16/2017Actions
Related to Foreman - Bug #20453: When cloning a host, build mode is offClosedTimo Goebel07/31/2017Actions
Related to Foreman - Bug #20820: ajax vars not loaded for host importClosedTimo Goebel08/31/2017Actions
Related to Foreman - Feature #22387: VMWare: Detect Operatingsystem when importing a VMNew01/23/2018Actions
Related to Foreman - Bug #23859: Ternary operation with vm_exists? in orchestration computeClosed06/08/2018Actions
Is duplicate of Foreman - Bug #19989: cannot edit hosts with names starting with "new"Duplicate06/13/2017Actions
Actions #1

Updated by The Foreman Bot about 7 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Timo Goebel
  • Pull request https://github.com/theforeman/foreman/pull/4195 added
Actions #2

Updated by Daniel Lobato Garcia about 7 years ago

  • Bugzilla link set to 1421441
Actions #3

Updated by Timo Goebel about 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #4

Updated by The Foreman Bot about 7 years ago

  • Pull request https://github.com/theforeman/foreman/pull/4401 added
Actions #5

Updated by Ohad Levy about 7 years ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/4401)
Actions #6

Updated by Ohad Levy about 7 years ago

  • translation missing: en.field_release set to 209
Actions #7

Updated by Dominic Cleal about 7 years ago

  • Related to Bug #19252: Associating VM fails with unknown permission for compute_resources_vms#associate added
Actions #8

Updated by Ohad Levy almost 7 years ago

  • Related to Bug #19414: Discovery host form errors out with Please try to update your request added
Actions #9

Updated by Dominic Cleal almost 7 years ago

  • Related to Bug #19419: Invalid syntax in aws fog extension added
Actions #10

Updated by Tomer Brisker almost 7 years ago

  • Related to Bug #19436: dropdowns on discovered host do not work added
Actions #11

Updated by Timo Goebel almost 7 years ago

  • Related to Bug #19566: Creating a new host VM on xen fails with: undefined method `new_host?' added
Actions #12

Updated by Ohad Levy almost 7 years ago

  • Is duplicate of Bug #19989: cannot edit hosts with names starting with "new" added
Actions #13

Updated by Timo Goebel over 6 years ago

  • Related to Bug #20453: When cloning a host, build mode is off added
Actions #14

Updated by Timo Goebel over 6 years ago

  • Related to Bug #20820: ajax vars not loaded for host import added
Actions #15

Updated by Timo Goebel about 6 years ago

  • Related to Feature #22387: VMWare: Detect Operatingsystem when importing a VM added
Actions #16

Updated by Anonymous almost 6 years ago

  • Related to Bug #23859: Ternary operation with vm_exists? in orchestration compute added
Actions

Also available in: Atom PDF