Project

General

Profile

Bug #18137

The Script katello-backup reports Permission denied messages

Added by Mario K over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
Backup & Restore
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hi!

The Script katello-backup reports Permission denied messages.

Details:
CentOS 7
Katello 3.2.2

Details:
root# rpm qa | grep '^katello[0-9]'
katello-3.2.2-1.el7.noarch
root# cat /etc/centos-release
CentOS Linux release 7.3.1611 (Core)
root# /usr/bin/katello-backup --online-backup --skip-pulp-content /data/backup/katellobackup ; echo $?
Starting backup: 2017-01-18 16:34:09 +0100
Creating backup folder /data/backup/katellobackup/katello-backup-2017-01-18T16:34:09+01:00
Backing up config files...
tar: Removing leading `/' from member names
tar: Removing leading `/' from hard link targets
Done.
Backing up postgres db...
-bash: /data/backup/katellobackup/katello-backup-2017-01-18T16:34:09+01:00/foreman.dump: Permission denied
-bash: /data/backup/katellobackup/katello-backup-2017-01-18T16:34:09+01:00/candlepin.dump: Permission denied
Done.
Backing up mongo db...
Done.
Done with backup: 2017-01-18 16:47:29 +0100
  • BACKUP Complete, contents can be found in: /data/backup/katellobackup/katello-backup-2017-01-18T16:34:09+01:00 **
    0
    root#

sincerely yours

Mario

History

#1 Updated by Mario K over 2 years ago

  • Subject changed from Permission denied Permission denied to The Script katello-backup reports Permission denied messages

#2 Updated by Eric Helms over 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Christine Fouant

#3 Updated by Eric Helms about 2 years ago

  • Legacy Backlogs Release (now unused) set to 211

#4 Updated by Christine Fouant about 2 years ago

  • Status changed from Assigned to Closed

I am unable to reproduce this. If you feel that this has been closed in error, or you have additional details, please comment below. Thanks!

[root@centos7-katello-3-2 vagrant]# cat /etc/centos-release
CentOS Linux release 7.3.1611 (Core)

[root@centos7-katello-3-2 vagrant]# rpm qa | grep '^katello[0-9]'
katello-3.2.2-1.el7.noarch

[root@centos7-katello-3-2 vagrant]# /usr/bin/katello-backup --online-backup --skip-pulp-content /tmp/backup ; echo $?
Starting backup: 2017-03-01 19:59:23 +0000
Creating backup folder /tmp/backup/katello-backup-2017-03-01T19:59:23+00:00
Backing up config files...
tar: /etc/puppet: Cannot stat: No such file or directory
tar: /var/lib/puppet/foreman_cache_data: Cannot stat: No such file or directory
tar: /var/lib/puppet/ssl: Cannot stat: No such file or directory
tar: Removing leading `/' from member names
tar: /etc/puppet: Cannot stat: No such file or directory
tar: /var/lib/puppet/foreman_cache_data: Cannot stat: No such file or directory
tar: /var/lib/puppet/ssl: Cannot stat: No such file or directory
tar: Removing leading `/' from hard link targets
tar: Exiting with failure status due to previous errors
Done.
Backing up postgres db...
Done.
Backing up mongo db...
Done.
Done with backup: 2017-03-01 19:59:24 +0000
  • BACKUP Complete, contents can be found in: /tmp/backup/katello-backup-2017-03-01T19:59:23+00:00 **
    0

[root@centos7-katello-3-2 vagrant]# ls al /tmp/backup/katello-backup-2017-03-01T19\:59\:23+00\:00/
total 1292
drwxrwx--
. 3 root postgres 4096 Mar 1 19:59 .
drwxr-xr-x. 3 root root 53 Mar 1 19:59 ..
rw-r--r-. 1 postgres postgres 182460 Mar 1 19:59 candlepin.dump
rw-r--r-. 1 root root 570579 Mar 1 19:59 config_files.tar.gz
rw-r--r-. 1 root root 14156 Mar 1 19:59 .config.snar
rw-r--r-. 1 postgres postgres 544073 Mar 1 19:59 foreman.dump
drwxr-xr-x. 4 root root 38 Mar 1 19:59 mongo_dump

Also available in: Atom PDF