Project

General

Profile

Bug #18173

Installing katello-agent results in error

Added by Sean O'Keeffe over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Client/Agent
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Running transaction
Installing : python-gofer-2.7.6-1.el7.noarch 1/19
Installing : gofer-2.7.6-1.el7.noarch 2/19
Installing : qpid-proton-c-0.14.0-2.el7.x86_64 3/19
Installing : python-qpid-proton-0.14.0-2.el7.x86_64 4/19
Installing : python-gofer-proton-2.7.6-1.el7.noarch 5/19
Installing : python-isodate-0.5.0-4.pulp.el7.noarch 6/19
Installing : python-pulp-common-2.10.3-1.el7.noarch 7/19
Installing : python-pulp-agent-lib-2.10.3-1.el7.noarch 8/19
Installing : python-pulp-rpm-common-2.10.3-1.el7.noarch 9/19
Installing : pulp-rpm-handlers-2.10.3-1.el7.noarch 10/19
Installing : tracer-common-0.6.12-4.el7.noarch 11/19
Installing : 1:python-html5lib-0.999-5.el7.noarch 12/19
Installing : python-beautifulsoup4-4.3.2-1.el7.noarch 13/19
Installing : python-psutil-2.2.1-1.el7.x86_64 14/19
Installing : katello-agent-fact-plugin-2.8.0-2.el7.noarch 15/19
Installing : libxslt-1.1.28-5.el7.x86_64 16/19
Installing : python-lxml-3.2.1-4.el7.x86_64 17/19
Installing : python2-tracer-0.6.12-4.el7.noarch 18/19
Installing : katello-agent-2.8.0-2.el7.noarch 19/19
Note: Forwarding request to 'systemctl enable goferd.service'.
Created symlink from /etc/systemd/system/multi-user.target.wants/goferd.service to /usr/lib/systemd/system/goferd.service.
Traceback (most recent call last):
File "/sbin/katello-tracer-upload", line 13, in <module>
main()
File "/sbin/katello-tracer-upload", line 10, in main
tracer_upload.upload_tracer_profile()
File "/usr/lib/yum-plugins/tracer_upload.py", line 56, in upload_tracer_profile
data = json.dumps({ "traces": get_apps(conduit) })
File "/usr/lib/yum-plugins/tracer_upload.py", line 47, in get_apps
for app in query_apps(conduit):
File "/usr/lib/yum-plugins/tracer_upload.py", line 38, in query_apps
return query.affected_applications().get()
File "/usr/lib/python2.7/site-packages/tracer/query.py", line 72, in get
return self._method(**self._kwargs)
File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 91, in trace_affected
packages = self._modified_packages()
File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 80, in _modified_packages
packages = self._PACKAGE_MANAGER.packages_newer_than(timestamp)
File "/usr/lib/python2.7/site-packages/tracer/resources/PackageManager.py", line 50, in packages_newer_than
packages_lists = [p.packages_newer_than(unix_time) for p in self.package_managers]
File "/usr/lib/python2.7/site-packages/tracer/packageManagers/rpm.py", line 84, in packages_newer_than
raise LockedDatabase() if str(e) == 'database is locked' else DatabasePermissions()
tracer.resources.exceptions.LockedDatabase: Package database is locked by another process
Verifying : libxslt-1.1.28-5.el7.x86_64 1/19
Verifying : gofer-2.7.6-1.el7.noarch 2/19
Verifying : python-beautifulsoup4-4.3.2-1.el7.noarch 3/19
Verifying : python-qpid-proton-0.14.0-2.el7.x86_64 4/19
Verifying : python-gofer-proton-2.7.6-1.el7.noarch 5/19
Verifying : python-gofer-2.7.6-1.el7.noarch 6/19
Verifying : python-pulp-common-2.10.3-1.el7.noarch 7/19
Verifying : katello-agent-fact-plugin-2.8.0-2.el7.noarch 8/19
Verifying : python-psutil-2.2.1-1.el7.x86_64 9/19
Verifying : python-lxml-3.2.1-4.el7.x86_64 10/19
Verifying : katello-agent-2.8.0-2.el7.noarch 11/19
Verifying : pulp-rpm-handlers-2.10.3-1.el7.noarch 12/19
Verifying : 1:python-html5lib-0.999-5.el7.noarch 13/19
Verifying : python-pulp-agent-lib-2.10.3-1.el7.noarch 14/19
Verifying : python-pulp-rpm-common-2.10.3-1.el7.noarch 15/19
Verifying : python2-tracer-0.6.12-4.el7.noarch 16/19
Verifying : tracer-common-0.6.12-4.el7.noarch 17/19
Verifying : python-isodate-0.5.0-4.pulp.el7.noarch 18/19
Verifying : qpid-proton-c-0.14.0-2.el7.x86_64 19/19

Installed:
katello-agent.noarch 0:2.8.0-2.el7

Dependency Installed:
gofer.noarch 0:2.7.6-1.el7 katello-agent-fact-plugin.noarch 0:2.8.0-2.el7 libxslt.x86_64 0:1.1.28-5.el7 pulp-rpm-handlers.noarch 0:2.10.3-1.el7
python-beautifulsoup4.noarch 0:4.3.2-1.el7 python-gofer.noarch 0:2.7.6-1.el7 python-gofer-proton.noarch 0:2.7.6-1.el7 python-html5lib.noarch 1:0.999-5.el7
python-isodate.noarch 0:0.5.0-4.pulp.el7 python-lxml.x86_64 0:3.2.1-4.el7 python-psutil.x86_64 0:2.2.1-1.el7 python-pulp-agent-lib.noarch 0:2.10.3-1.el7
python-pulp-common.noarch 0:2.10.3-1.el7 python-pulp-rpm-common.noarch 0:2.10.3-1.el7 python-qpid-proton.x86_64 0:0.14.0-2.el7 python2-tracer.noarch 0:0.6.12-4.el7
qpid-proton-c.x86_64 0:0.14.0-2.el7 tracer-common.noarch 0:0.6.12-4.el7

Complete!

Associated revisions

Revision e35caf2d (diff)
Added by Sean O'Keeffe over 3 years ago

Fixes #18173 - Dont run katello-tracer-upload during install

This results in a error because yum has a lock on the RPM DB which katello-tracer-upload needs to run.

Revision 7e5d969a
Added by Justin Sherrill over 3 years ago

Merge pull request #354 from sean797/18173

Fixes #18173 - Dont run katello-tracer-upload during install

History

#1 Updated by Anonymous over 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#2 Updated by Sean O'Keeffe over 3 years ago

  • Pull request https://github.com/Katello/katello-packaging/pull/354 added

Also available in: Atom PDF