Bug #18278

Verbosity level 0 triggers "TypeError no implicit conversion of nil into String" on run playbook command

Added by Ivan Necas over 1 year ago. Updated 7 days ago.

Status:Closed
Priority:Normal
Assignee:Daniel Lobato Garcia
Category:-
Target version:1.11.0
Difficulty: Team Backlog:
Triaged: Fixed in Releases:
Bugzilla link: Found in Releases:
Pull request:https://github.com/theforeman/foreman_ansible/pull/74

Description

2017-01-26T22:50:16 c65b928c [foreman-tasks/dynflow] [E] error while dispatching request to runner f0bb6102-c574-45fd-bb36-45ac683773c5:TypeError no implicit conversion of nil into String:
 |  /home/inecas/Projects/ws/foreman-rex/foreman-tasks/lib/foreman_tasks_core/runner/command_runner.rb:8:in `spawn'
 | /home/inecas/Projects/ws/foreman-rex/foreman-tasks/lib/foreman_tasks_core/runner/command_runner.rb:8:in `initialize_command'
 | /home/inecas/Projects/ws/foreman-rex/foreman_ansible/lib/foreman_ansible_core/playbook_runner.rb:21:in `block in start'
 | /home/inecas/Projects/ws/foreman-rex/foreman_ansible/lib/foreman_ansible_core/playbook_runner.rb:20:in `chdir'
 | /home/inecas/Projects/ws/foreman-rex/foreman_ansible/lib/foreman_ansible_core/playbook_runner.rb:20:in `start'
 | /home/inecas/Projects/ws/foreman-rex/foreman-tasks/lib/foreman_tasks_core/runner/dispatcher.rb:29:in `start_runner'
 | /home/inecas/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/dynflow-0.8.18/lib/dynflow/actor.rb:6:in `on_message'
 | /home/inecas/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/concurrent-ruby-edge-0.2.3/lib/concurrent/actor/context.rb:46:in `on_envelope'
 | /home/inecas/Projects/ws/foreman-rex/foreman-tasks/lib/foreman_tasks_core/runner/dispatcher.rb:22:in `on_envelope'
 | /home/inecas/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/concurrent-ruby-edge-0.2.3/lib/concurrent/actor/behaviour/executes_context.rb:7:in `on_envelope'
 | /home/inecas/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/concurrent-ruby-edge-0.2.3/lib/concurrent/actor/behaviour/abstract.rb:25:in `pass'
 | /home/inecas/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/dynflow-0.8.18/lib/dynflow/actor.rb:26:in `on_envelope'
 | /home/inecas/.rbenv/versions/2.1.0/lib/ruby/gems/2.1.0/gems/concurrent-ruby-edge-0.2.3/lib/concurrent/actor/behaviour/abstract.rb:

Workaround is to increase the verbosity level

Associated revisions

Revision 0ac98d55
Added by Daniel Lobato García over 1 year ago

Fixes #18278 - Validate verbosity levels

Verbosity levels were defaulting to the wrong one (0, which caused an
error). Now it offers a sensible list of possible verbosities with the
description of what they are.

History

#1 Updated by Ivan Necas over 1 year ago

This seems to be regression from http://projects.theforeman.org/issues/18108/

#2 Updated by Daniel Lobato Garcia over 1 year ago

Alternatively I think it'd be best to provide a collection of available settings, Ansible provides -v, -vv and -vvv so just allow 1, 2 and 3

#3 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Daniel Lobato Garcia
  • Pull request https://github.com/theforeman/foreman_ansible/pull/74 added

#4 Updated by Anonymous over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Daniel Lobato Garcia over 1 year ago

  • Target version set to 1.11.0

Also available in: Atom PDF