Project

General

Profile

Actions

Bug #1830

closed

Puppet run triggers "no puppet proxy defined - cant continue" after 1.0 upgrade

Added by Keiran Sweet almost 12 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Puppet integration
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

I've just upgraded from 0.4.2 -> 1.0.1 without any major issues, however i do use the run Puppet functionality of foreman as a stop gap until I get mcollective sorted out.

After upgrade, testing the puppet run functionality on existing nodes was triggering the no "puppet proxy defined - cant continue" error message in the top right hand corner of the node information screen.

Digging a little deeper seems to show that the puppet_proxy_id value in the database inst being updated with the new Puppet proxy value, the workaround for this at the moment is either:

Manual approach:
For each host click the edit button, ensure your Puppetmaster value is set as required and click submit, the puppet_proxy_id value will be updated in the database. In my case, the puppetmaster value was already correct, but the process of jumping in and out of the edit host screen was enough to trigger a database update for the node.

Automatic approach:
Write some MySQL to update the values of each hosts puppet_proxy_id values to reference the required proxy, this should be simple enough if you have one puppet proxy, however it could get a little complex if you have many hosts and multiple proxies.

Not a huge issue, but something that needs to be looked into when upgrading.

Thanks,

K


Files

no_proxy_defined_-_cleaned.jpg View no_proxy_defined_-_cleaned.jpg 171 KB Keiran Sweet, 08/20/2012 08:34 AM

Related issues 1 (0 open1 closed)

Related to Foreman - Bug #3214: No location / Organization if host added by default from puppet runClosedDaniel Lobato Garcia10/08/2013Actions
Actions

Also available in: Atom PDF