Project

General

Profile

Bug #18344

Exporting composite content views results in an errant 1 in the file

Added by Andrew Kofink almost 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
content-views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When doing a
```bash
hammer csv content-views --export --verbose --organization $ORGNAME
```
the content views look fine but the composite content views have an extra field in them that prevent an import from working.
```
Name,Label,Organization,Composite,Repositories or Composites,Lifecycle Environments
CV Rsyslog EL7,CV_Rsyslog_EL7,CIT,No,rsyslog-el7-64-8,"Library,stable"
CV Repose,CV_Repose,CIT,No,repose-noarch,"Library,stable"
CV Puppet 4 EL7,CV_Puppet_4_EL7,CIT,No,puppet-el7-64-PC1,Library
CV Puppet 3 EL7,CV_Puppet_3_EL7,CIT,No,"puppet-el7-64-r10k,puppet-el7-64-products,puppet-el7-64-dependencies","Library,stable"
CV PostgreSQL95 EL7,CV_PostgreSQL95_EL7,CIT,No,postgresql95-el7-64,"Library,stable"
CV PostgreSQL93 EL7,CV_PostgreSQL93_EL7,CIT,No,postgresql93-el7-64,"Library,stable"
CV Plight EL7,CV_Plight_EL7,CIT,No,rackspace-el7-64-plight,"Library,stable"
CV LLDP EL7,CV_LLDP_EL7,CIT,No,lldp-el7-64,"Library,stable"
CV Katello Agent EL7,CV_Katello_Agent_EL7,CIT,No,katello-agent-el7-64-3_2,"Library,stable"
CV Identity EL7,CV_Identity_EL7,CIT,No,"identity-el7-noarch,identity-el7-64-cadir",Library
CV Crowdstrike EL7,CV_Crowdstrike_EL7,CIT,No,crowdstrike-el7-64,"Library,stable"
CV Cloudpassage EL7,CV_Cloudpassage_EL7,CIT,No,cloudpassage-el7-64,"Library,stable"
CV CentOS 7,CV_CentOS_7,CIT,No,"epel7-64,centos7-64-updates,centos7-64-os,centos7-64-fasttrack,centos7-64-extras","Library,stable"
CCV Generic EL7,1,CCV_Generic_EL7,CIT,Yes,"CV Rsyslog EL7,CV Repose,CV Puppet 3 EL7,CV PostgreSQL95 EL7,CV Plight EL7,CV Katello Agent EL7,CV Crowdstrike EL7,CV Cloudpassage EL7,CV CentOS 7","Library,staging,prod"
```

Notice a 1 in the second field on the last line.


Related issues

Has duplicate Hammer CLI CSV - Bug #18723: Hammer csv content-views fails to export/import Composite Content ViewsDuplicate2017-02-28
Is duplicate of Hammer CLI CSV - Bug #18829: Hammer csv content-view-filters fails to export a date-based Erratum filterDuplicate2017-03-07

History

#1 Updated by Fran Garcia almost 6 years ago

  • Has duplicate Bug #18723: Hammer csv content-views fails to export/import Composite Content Views added

#2 Updated by Thomas McKay over 5 years ago

  • Is duplicate of Bug #18829: Hammer csv content-view-filters fails to export a date-based Erratum filter added

#3 Updated by Thomas McKay over 5 years ago

  • Status changed from New to Duplicate

#4 Updated by Thomas McKay over 5 years ago

  • Status changed from Duplicate to Closed
  • Legacy Backlogs Release (now unused) set to 230

Also available in: Atom PDF