Project

General

Profile

Bug #18424

[candlepin-2.0] import manifest after delete gives: Runtime Error Index: 0, Size: 0 at java.util.ArrayList.rangeCheck:653

Added by Thomas McKay over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Urgent
Assignee:
-
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

To reproduce:
+ import manifest
+ enable repos (not sure required step for reproducer)
+ delete manifest
+ import same manifest

2017-02-08 15:01:01,616 [thread=http-bio-8443-exec-6] [req=91ff7192-38db-4370-9111-1389725c6ed1, org=] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/owners/examplecorp/uebercert
2017-02-08 15:01:01,655 [thread=http-bio-8443-exec-6] [req=91ff7192-38db-4370-9111-1389725c6ed1, org=examplecorp] ERROR org.candlepin.common.exceptions.mappers.CandlepinExceptionMapper - Runtime Error Index: 0, Size: 0 at java.util.ArrayList.rangeCheck:653
java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.ArrayList.rangeCheck(ArrayList.java:653) ~[na:1.8.0_111]
    at java.util.ArrayList.get(ArrayList.java:429) ~[na:1.8.0_111]
    at org.candlepin.resource.OwnerResource.getUeberCertificate(OwnerResource.java:1422) ~[OwnerResource.class:na]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.8.0_111]
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[na:1.8.0_111]

History

#1 Updated by Thomas McKay over 5 years ago

  • Bugzilla link set to 1420406

#2 Updated by Justin Sherrill over 5 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

closing since this is pure candlepin issue.

Also available in: Atom PDF