Project

General

Profile

Bug #18434

On CVV promotion, don't update revision number on a repo in pulp if no content has changed

Added by John Mitsch over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

This will greatly speed up pulp tasks as pulp skips a bunch of steps if the revision number hasn't changed. In particular, this will speed up capsule syncs triggered by a CVV promotion


Related issues

Is duplicate of Katello - Bug #18032: Regression: Syncing large Library of content from Katello to Proxy takes hours even if no content changesClosed2017-01-11

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to John Mitsch
  • Pull request https://github.com/Katello/katello/pull/6597 added

#2 Updated by Eric Helms over 5 years ago

  • Status changed from Ready For Testing to Duplicate
  • Legacy Backlogs Release (now unused) set to 166
  • Pull request deleted (https://github.com/Katello/katello/pull/6597)

#3 Updated by Eric Helms over 5 years ago

  • Is duplicate of Bug #18032: Regression: Syncing large Library of content from Katello to Proxy takes hours even if no content changes added

Also available in: Atom PDF