Project

General

Profile

Bug #18515

remote execution job detail page does not show all the details provided by user when scheduling it - e.g. "Start after" datetime

Added by Adam Ruzicka over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Usability
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1417099

Description of problem:
remote execution job detail page does not show all the details provided by user when scheduling it - e.g. "Start after" datetime

Version-Release number of selected component (if applicable):
satellite-6.2.6-2.0.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Say you are starting new ReX job and configure this:
Display advanced fields
Schedule: Schedule future execution
Start after: 9:50
Start before: 10:00
2. Hit [Submit] and on detail page search for this info

Actual results:
No info about time restrictions, maybe others as well are missing.

Expected results:
E.g. there is (maybe it could fit here?):
~~~
following user inputs were provided

  • command: yum -y downgrade ksh-20120801-22.el7_1.2"
    ~~~

Associated revisions

Revision 2e134e56 (diff)
Added by Ivan Necas about 2 years ago

Fixes #18515 - add scheduling helpers + tests (#243)

  • Fixes #18515 - add scheduling helpers

Revision 3beeae44 (diff)
Added by adamruzicka about 2 years ago

Fixes #18515 - Show scheduling info on job invocation overview tab

History

#1 Updated by Adam Ruzicka over 2 years ago

  • Category set to Usability
  • Target version set to 113

#2 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Adam Ruzicka
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/229 added

#3 Updated by Ivan Necas about 2 years ago

  • Target version changed from 113 to 1.12.0

#4 Updated by Ivan Necas about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Adam Ruzicka about 2 years ago

  • Status changed from Closed to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-tasks/pull/243 added

Reopening because not all of the required PRs were merged

#6 Updated by Ivan Necas about 2 years ago

  • Target version changed from 1.12.0 to 1.12.4

#7 Updated by Anonymous about 2 years ago

  • Status changed from Ready For Testing to Closed

#8 Updated by Ivan Necas about 2 years ago

  • Target version changed from 1.12.4 to 1.13.1

#9 Updated by Ivan Necas almost 2 years ago

  • Legacy Backlogs Release (now unused) set to 262

Also available in: Atom PDF