Project

General

Profile

Bug #18546

pulp errors on capsule install

Added by John Mitsch over 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Installer
Target version:
Difficulty:
hard
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I got these (attached) errors when spinning up a capsule using forklift (dev environment). The actual install and playbook finished fine, but when syncing repos, I hit "not all pulp workers running" errors. attached is /var/log/message output from the capsule. These errors happened around the time the capsule spun up.

a discussion on IRC (#theforeman-dev 2/16 14:05) led us to think that the certs are not created when pulp services are started during the install.

Its also worth noting that the pulp services returned OK statuses.

A restart of pulp services appears to have fixed the problem

pulp-capsule-error pulp-capsule-error 12.5 KB John Mitsch, 02/16/2017 02:30 PM

History

#1 Updated by John Mitsch over 5 years ago

  • Description updated (diff)

#2 Updated by John Mitsch over 5 years ago

  • Description updated (diff)

#3 Updated by Justin Sherrill over 5 years ago

  • Priority changed from Normal to High
  • Legacy Backlogs Release (now unused) set to 211
  • Difficulty set to hard

#4 Updated by Eric Helms about 5 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) changed from 211 to 166

Also available in: Atom PDF