Project

General

Profile

Bug #18572

Hammer - Unable to remove repo content using repo name if more than one repository with same name exists

Added by Swapnil Abnave over 2 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Category:
Hammer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from: https://bugzilla.redhat.com/1413145

Description of problem:
Unable to remove repo content using repo name if more than one repository with same name exists.
If more than one repo with the same name but in different products/organizations exists, it is not possible to remove its content using repo name via hammer.
Most of the `repository` subcommands allows to specify --product/--product-id and --organization/--organization-id but `remove-content` allows to provide only repo's --name or --id.

> hammer> repository remove-content --help  
> Usage:
>     repository remove-content [OPTIONS]
> Options:
>  --id ID                       repository ID
>  --ids IDS                     Array of content ids to remove
>                               Comma separated list of values.
> --name NAME                   Repository name to search by
> -h, --help                    print help
> hammer> 

> repository create --name a --product 1 --content-type yum --url http://inecas.fedorapeople.org/fakerepos/zoo3/ --organization-id 1
> repository create --name a --product 2 --content-type yum --url http://inecas.fedorapeople.org/fakerepos/zoo3/ --organization-id 1
> repository synchronize --name a --product 1 --organization-id 1
> repository synchronize --name a --product 2 --organization-id 1
> repository remove-content --name a --ids 4403  
> Could not remove content:
>  Error: found more than one repository
> repository remove-content --name a --ids 4403 --product 1 --organization-id=1
> Could not remove content:
>  Error: Unrecognised option '--product'

Version-Release number of selected component (if applicable):
Satellite 6.3.0 Snap 8.0 / Foreman 1.13.2.2
tfm-rubygem-hammer_cli_foreman-0.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. Create 2 repos with the same name but in different products
2. Try to remove content providing only repo name
3. Try to remove content providing repo name and product or organization name/id

Actual results:
Error `found more than one repository` or
Error `Unrecognised option '--product`

Expected results:
It should be possible to specify organization/product like for other repository subcommands.


Related issues

Is duplicate of Katello - Bug #15555: Hammer repository remove-content should allow reposotiry ID resolution by name, organization, and productClosed2016-06-30

History

#1 Updated by Dominic Cleal over 2 years ago

  • Project changed from Hammer CLI to Katello
  • Category deleted (Other commands)

#2 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/484 added

#3 Updated by Swapnil Abnave over 2 years ago

  • Category set to Hammer

#4 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) set to 211

#5 Updated by Andrew Kofink over 2 years ago

  • Is duplicate of Bug #15555: Hammer repository remove-content should allow reposotiry ID resolution by name, organization, and product added

#6 Updated by Andrew Kofink over 2 years ago

  • Status changed from Ready For Testing to Duplicate

Also available in: Atom PDF