Project

General

Profile

Feature #18584

Api for listing all auth sources

Added by Tomáš Strachota over 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Category:
Authentication
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Currently it's possible to list only ldap auth sources. We need to create an endpoint for listing all auth sources to provide users one unified place to look into. This would serve as API equivalent to Auth source select box in user edit/create form in the UI.

It's important support for CLI workflows.


Related issues

Is duplicate of Foreman - Bug #15286: Missing API for external auth sourcesClosed2016-06-03
Blocks Hammer CLI - Feature #4356: Improve ways of passing auth source when creating a userDuplicate2014-02-17
Blocks Hammer CLI - Feature #18805: Creating external user-group does not have any option --auth-source as a input parameter.Duplicate2017-03-06
Blocks Hammer CLI - Feature #19651: Command for listing all auth sourcesClosed2017-05-24

History

#1 Updated by Tomáš Strachota over 2 years ago

  • Blocks Feature #4356: Improve ways of passing auth source when creating a user added

#2 Updated by Tomáš Strachota about 2 years ago

  • Blocks Feature #18805: Creating external user-group does not have any option --auth-source as a input parameter. added

#3 Updated by Marek Hulán about 2 years ago

  • Target version changed from 115 to 1.13.4

This might be dup of #15286

#4 Updated by Tomáš Strachota about 2 years ago

#5 Updated by Marek Hulán almost 2 years ago

  • Target version changed from 1.13.4 to 1.14.0

#6 Updated by Marek Hulán almost 2 years ago

  • Target version changed from 1.14.0 to 1.14.3

#7 Updated by Dominik Hlavac Duran almost 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominik Hlavac Duran

#8 Updated by Daniel Lobato Garcia almost 2 years ago

  • Status changed from Assigned to Duplicate

From what I see this is a duplicate of http://projects.theforeman.org/issues/15286 , let's just make the endpoint return also the Internal auth source in #15286 fix and that'd be it.

#9 Updated by Daniel Lobato Garcia almost 2 years ago

  • Is duplicate of Bug #15286: Missing API for external auth sources added

Also available in: Atom PDF