Project

General

Profile

Bug #1860

Successful rename of host displays old name on host page

Added by Greg Sutcliffe over 6 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

After renaming a machine called "ubuntu64" to "services", I now see the attached image for my Host page. Looks like the rename is missing a step somewhere. All DNS etc seems ok, so it's just cosmetic.

2012-09-13-153950_1462x215_scrot.png View 2012-09-13-153950_1462x215_scrot.png 36.7 KB Top of Host page + URL after a rename Greg Sutcliffe, 09/13/2012 10:46 AM
2012 09 13 153950 1462x215 scrot

History

#1 Updated by Greg Sutcliffe over 6 years ago

  • Category set to Web Interface

#2 Updated by Joseph Magen over 6 years ago

  • Status changed from New to Feedback

Unable to replicate
Title in view is @host.to_label --> @host.name. Seems OK.

#3 Updated by Sam Kottler over 6 years ago

Like Joseph, I can't reproduce this. Greg, can you provide more info or try again with develop?

#4 Updated by Greg Sutcliffe over 6 years ago

  • Status changed from Feedback to Assigned

I can reproduce it, but only on Libvirt hosts, not Bare Metal (haven't tried other hypervisors). I've sent Amos a ton of debug info. Specifically, look at the <title> page element on a Libvirt hosts it gets doubled up:

<title>foo.bar.comfoo.bar.com</title>

Despite this, it renders properly (weird). More weird is what happens when you rename this host - only one of the duplicates changes:

<title>baz.bar.comfoo.bar.com</title>

I suspect it's related to the fact that the name change doesn't alter the underlying XML from libvirt, and we're using it somehow....

#5 Updated by Joseph Magen over 4 years ago

  • Description updated (diff)

I tried again and could not reproduce

#6 Updated by Dominic Cleal over 4 years ago

  • Status changed from Assigned to Resolved

At some point the title used to show both the libvirt "domain" name and our record of the hostname. The CR name has been removed since.

Also available in: Atom PDF