Project

General

Profile

Bug #18644

Errata Update takes longer time @scale

Added by John Mitsch about 2 years ago. Updated 10 months ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1418174

Description of problem:

Started errata with 2500 applicable hosts (has 6k nodes in setup)
It took 30+ mins to initiate errata on 650 nodes.

number of transactions processed by server
one transaction can have 0 - more queries.

postgres=# SELECT sum(xact_commit+xact_rollback) FROM pg_stat_database;
sum
----------
57422892
(1 row)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start errata on 2k nodes
2.
3.

Actual results:

Expected results:

Additional info:


Related issues

Is duplicate of Katello - Bug #15366: Errata Install to Content Host takes too long and doesn't scale wellClosed2016-06-09

History

#1 Updated by John Mitsch about 2 years ago

  • Subject changed from Errata Update takes longer time @scale to Errata Update takes longer time @scale
  • Target version set to 169

#2 Updated by John Mitsch about 2 years ago

  • Status changed from New to Duplicate

#3 Updated by John Mitsch about 2 years ago

  • Is duplicate of Bug #15366: Errata Install to Content Host takes too long and doesn't scale well added

#4 Updated by Eric Helms about 2 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF