Project

General

Profile

Bug #18648

sync to smart proxy with content errors "Couldn't find SmartProxy with 'id'=2 [WHERE 1=0]"

Added by Thomas McKay about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Foreman Proxy Content
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

To reproduce, create a capsule w/ "content" and attempt to sync a lifecycle environment.

Error happens here

https://github.com/Katello/katello/blob/master/app/lib/actions/pulp/abstract.rb#L10

but there may be other locations.

It was suggested that a possible solution is to set User.current = User.anonymous_api_admin


Related issues

Is duplicate of Katello - Bug #18656: syncing a capsule fails with ActiveRecord::RecordNotFound Couldn't find SmartProxy with 'id'=2Closed2017-02-23

History

#2 Updated by Thomas McKay about 5 years ago

  • Status changed from New to Duplicate

#3 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

#4 Updated by Eric Helms about 5 years ago

  • Is duplicate of Bug #18656: syncing a capsule fails with ActiveRecord::RecordNotFound Couldn't find SmartProxy with 'id'=2 added

Also available in: Atom PDF