Project

General

Profile

Bug #18652

Listing Applicable hosts for any errata takes long time at scale

Added by John Mitsch over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1417437

Description of problem:

Have 6k hosts registered to setup.
Selected an errata which is applicable for 4K+ hosts. Took more than 6 mins to list

content -> errata -> any errata -> Applicable content Hosts of respective errata

GET https://<hostname>/api/v...h=(applicable_errata%3D+%22RHBA-2015:2115%22+) 200 OK 6m 35s

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.with Scale environment
content -> errata -> any errata -> Applicable content Hosts of respective errata
2.
3.

Actual results:

List Applicable content Hosts of respective errata at scale takes long time

Expected results:

Take lesser time to open
Additional info:


Related issues

Is duplicate of Katello - Bug #18376: showing Content -> Errata with "Installable" checkbox checked hakes too much time and memory when on scaleClosed2017-02-02

History

#1 Updated by John Mitsch over 5 years ago

  • Target version set to 169

#2 Updated by John Mitsch over 5 years ago

  • Description updated (diff)

#3 Updated by John Mitsch over 5 years ago

  • Status changed from New to Duplicate

#4 Updated by John Mitsch over 5 years ago

  • Is duplicate of Bug #18376: showing Content -> Errata with "Installable" checkbox checked hakes too much time and memory when on scale added

#5 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF