Project

General

Profile

Bug #18678

notification actions always open an external tab

Added by Ohad Levy over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Notifications
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

https://github.com/theforeman/foreman/blob/develop/webpack/assets/javascripts/react_app/components/notifications/NotificationDropdown.js#L9 hard code to always Opens the linked document in a new window or tab, it should be configurable.

additionally, clicking on an action should close the notification drawer.


Related issues

Related to Discovery - Feature #18677: add UI notifications on discovered host eventClosed2017-02-26
Related to Foreman - Bug #18426: Provide support for Notification actionsClosed2017-02-08

Associated revisions

Revision a29d5438 (diff)
Added by matan werbner over 4 years ago

Fixes #18957,#18193,#18678,#18853 - notifications redux

Refactored notifications to work with redux, fixed
several UI related bugs, added tests.
flux is now unused, this is based on @gailsteiger's
previous work.

Revision e2b7102e (diff)
Added by matan werbner over 4 years ago

Fixes #18957,#18193,#18678,#18853 - notifications redux

Refactored notifications to work with redux, fixed
several UI related bugs, added tests.
flux is now unused, this is based on @gailsteiger's
previous work.

History

#1 Updated by Ohad Levy over 4 years ago

  • Related to Feature #18677: add UI notifications on discovered host event added

#2 Updated by Ohad Levy over 4 years ago

  • Related to Bug #18426: Provide support for Notification actions added

#3 Updated by Gail Steiger over 4 years ago

IMHO, notification actions opening an external tab is a feature, not a bug.

Why should clicking an action close the notification drawer?

#4 Updated by Ohad Levy over 4 years ago

Gail Steiger wrote:

IMHO, notification actions opening an external tab is a feature, not a bug.

if the link is within the app, i can't see how opening it in a new tab makes sense, i agree in some cases you want external urls, so we need both.

Why should clicking an action close the notification drawer?

for the case where i am redirected to another page within the app, i think it make sense to close the drawer (otherwise the first thing I'll do is to close it).

#5 Updated by Liza Gilman over 4 years ago

  • Assignee set to Liza Gilman

#6 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4403 added

#7 Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/foreman/pull/4401 added

#8 Updated by matan werbner over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#9 Updated by Ohad Levy over 4 years ago

  • Assignee changed from Liza Gilman to matan werbner
  • Legacy Backlogs Release (now unused) set to 209
  • Pull request deleted (https://github.com/theforeman/foreman/pull/4403)

Also available in: Atom PDF