Project

General

Profile

Bug #18698

no new packages message is shown when there is a new package on repository sync

Added by John Mitsch over 2 years ago. Updated 12 months ago.

Status:
Needs design
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

To reproduce:
- Sync a repo that you have access to
- add a package to that repo (run createrepo . again)
- resync the repo
- check for "No new packages" output in task

expected results:
"1 package added" is shown

History

#1 Updated by John Mitsch over 2 years ago

happens only some of the time, unsure what is causing it

#2 Updated by Eric Helms over 2 years ago

  • Status changed from New to Needs design
  • Legacy Backlogs Release (now unused) set to 114

#3 Updated by John Mitsch over 2 years ago

This is probably only happening when a package is "new to pulp" aka in another repository, we need to investigate more.

#4 Updated by Ondřej Pražák about 2 years ago

I encountered this today when syncing newly enabled RH repo.

1) Import manifest, enable the Tools repo
2) Go to Sync Status, select the newly enabled repo, click 'Synchronize Now'
3) Wait for syncing to finish, Result: Syncing Complete, Details: No new packages
4) Go to the synced repo through Product page
5) You will see that there are new packages that must have been added just now since this was the first repo sync

Also available in: Atom PDF