Project

General

Profile

Bug #18705

Clients show Advisory not applicable for this system when errata is applicable and event count is not zero

Added by Brad Buckingham over 1 year ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Errata Management
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Brad
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1420671

Description of problem:
Clients registered to server show Security Errata available through the webui, but when attempting to apply the errata to the system following message is generated :

Advisory "RHSA-2017:0036" not found applicable for this system
Advisory "RHSA-2017:0184" not found applicable for this system
Advisory "RHSA-2017:0063" not found applicable for this system

How reproducible:
For rhel-6 and rhel-7 client

Steps to Reproduce:

$ hammer content-host info --id 182
Name: slvdcfvdwks01.test.net
ID: 7172e94b-1ecc-46a0-9d70-b525199f197f
Katello Agent Installed: yes
Location: None
Lifecycle Environment: LAB
Content View: eue-rhel7-server-x86_64-cv
Entitlement Status: valid
Release Version: 7Server
Autoheal: true
Security Errata: 2
Bugfix Errata: 13
Enhancement Errata: 0

$ hammer host errata list --host-id 182
-------------------------------------|----------------|----------|-------------------------------------------------------------|------------
ID | ERRATUM ID | TYPE | TITLE | INSTALLABLE
-------------------------------------|----------------|----------|-------------------------------------------------------------|------------
702f6986-1a72-4a29-ae42-ae2f54e1a9cc | RHBA-2017:0198 | bugfix | Satellite 6.2.7 Tools Async Release |
8a8fe109-8913-4113-ad63-cc73f11f2e57 | RHBA-2017:0028 | bugfix | microcode_ctl bug fix update |
f4d298fe-6147-4d37-8cdd-8b0edf7f0216 | RHSA-2017:0086 | security | Important: kernel security, bug fix, and enhancement update |
df579dfd-4d67-4358-9f6f-446e754a5bfa | RHBA-2017:0081 | bugfix | openssh bug fix update |
d1585311-5ec6-4631-be7d-92e9413c1295 | RHBA-2017:0084 | bugfix | selinux-policy bug fix update |
ae708ed0-2e9b-4af8-a749-293f9ad0a5e4 | RHBA-2017:0082 | bugfix | libpciaccess bug fix update |
a3d04477-29f6-419d-886e-53ccadc23778 | RHSA-2017:0062 | security | Important: bind security update |
a2a7e49a-f6be-48d3-a02c-6f526d67d8c2 | RHBA-2017:0075 | bugfix | libsemanage and policycoreutils bug fix update |
9cb7eb61-fbc6-46ae-bae7-b6581ffa9b7c | RHBA-2017:0078 | bugfix | sssd bug fix update |
3cfb544a-3dc4-4c1c-943a-3a239aad37e8 | RHBA-2017:0103 | bugfix | firewalld bug fix update |
3504de2d-a772-4858-a7e6-07bab670b28d | RHBA-2017:0074 | bugfix | lvm2 bug fix update |
32619a84-ed9f-4f93-bb24-4fa33be11f2c | RHBA-2017:0069 | bugfix | samba bug fix update |
1a2e5e6e-dd3e-42cf-9a1d-1f661aedce88 | RHBA-2017:0104 | bugfix | libnl3 bug fix update |
0f5b33fb-f29d-4d57-83ee-163346099456 | RHBA-2017:0076 | bugfix | device-mapper-multipath bug fix update |
06f24063-120d-4cb6-831f-01f9585c22cf | RHBA-2017:0100 | bugfix | xfsprogs bug fix update |
-------------------------------------|----------------|----------|-------------------------------------------------------------|------------

client
  1. yum update --security
    Loaded plugins: package_upload, product-id, search-disabled-repos, subscription-manager
    Enterprise_Unix_Engineering_eue_cust_content_rhel7_eue-cust-content-rhel7 | 2.1 kB 00:00:00
    rhel-7-server-rpms | 2.0 kB 00:00:00
    rhel-7-server-satellite-tools-6.2-rpms | 2.1 kB 00:00:00
    --> python-pulp-common-2.8.7.3-1.el7sat.noarch from @rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> sssd-common-pac-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> libsmbclient-4.4.4-9.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> kernel-3.10.0-514.6.1.el7.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> selinux-policy-3.13.1-102.el7_3.7.noarch from @rhel-7-server-rpms removed (updateinfo)
    --> policycoreutils-python-2.5-11.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> kernel-tools-3.10.0-514.2.2.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libsemanage-python-2.5-4.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> sssd-ipa-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> samba-client-libs-4.4.4-9.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-libs-1.02.135-1.el7_3.2.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> libsss_nss_idmap-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> openssh-server-6.6.1p1-31.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> libsss_autofs-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-event-libs-1.02.135-1.el7_3.2.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-libs-9.9.4-38.el7_3.1.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> python-firewall-0.4.3.2-8.1.el7_3.noarch from rhel-7-server-rpms removed (updateinfo)
    --> python-sssdconfig-1.14.0-43.el7_3.11.noarch from rhel-7-server-rpms removed (updateinfo)
    --> kpartx-0.4.9-99.el7_3.1.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 2:microcode_ctl-2.1-16.1.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> python-pulp-agent-lib-2.8.7.5-1.el7sat.noarch from rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> sssd-common-pac-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 7:lvm2-libs-2.02.166-1.el7_3.1.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-event-1.02.135-1.el7_3.2.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> openssh-6.6.1p1-31.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> kernel-tools-libs-3.10.0-514.6.1.el7.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-ipa-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> libwbclient-4.4.4-12.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> samba-client-libs-4.4.4-12.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> openssh-server-6.6.1p1-33.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> xfsprogs-4.5.0-8.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> python-pulp-agent-lib-2.8.7.3-1.el7sat.noarch from @rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> firewalld-0.4.3.2-8.el7.noarch from @anaconda/7.3 removed (updateinfo)
    --> libpciaccess-0.13.4-3.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> kernel-tools-3.10.0-514.6.1.el7.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> python-perf-3.10.0-514.2.2.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> samba-common-4.4.4-12.el7_3.noarch from rhel-7-server-rpms removed (updateinfo)
    --> libsss_sudo-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-license-9.9.4-38.el7_3.noarch from @rhel-7-server-rpms removed (updateinfo)
    --> 7:lvm2-2.02.166-1.el7_3.1.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libnl3-3.2.28-2.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libnl3-3.2.28-3.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-utils-9.9.4-38.el7_3.1.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-libs-lite-9.9.4-38.el7_3.1.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-client-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> firewalld-filesystem-0.4.3.2-8.1.el7_3.noarch from rhel-7-server-rpms removed (updateinfo)
    --> sssd-ldap-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-libs-lite-9.9.4-38.el7_3.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-common-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> policycoreutils-python-2.5-9.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libsmbclient-4.4.4-12.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> openssh-6.6.1p1-33.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-krb5-common-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> firewalld-filesystem-0.4.3.2-8.el7.noarch from @anaconda/7.3 removed (updateinfo)
    --> libsss_idmap-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libsss_autofs-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-license-9.9.4-38.el7_3.1.noarch from rhel-7-server-rpms removed (updateinfo)
    --> sssd-ad-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-event-libs-1.02.135-1.el7_3.1.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 7:lvm2-2.02.166-1.el7_3.2.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> python-pulp-rpm-common-2.8.7.6-1.el7sat.noarch from rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> pulp-rpm-handlers-2.8.7.5-1.el7sat.noarch from @rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> policycoreutils-2.5-11.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> selinux-policy-3.13.1-102.el7_3.13.noarch from rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-1.02.135-1.el7_3.2.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-proxy-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-ldap-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> openssh-clients-6.6.1p1-31.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> python-perf-3.10.0-514.6.1.el7.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-event-1.02.135-1.el7_3.1.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-ad-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-libs-1.02.135-1.el7_3.1.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libsss_idmap-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> libsss_nss_idmap-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> kpartx-0.4.9-99.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> selinux-policy-targeted-3.13.1-102.el7_3.13.noarch from rhel-7-server-rpms removed (updateinfo)
    --> 7:device-mapper-1.02.135-1.el7_3.1.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-proxy-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> python-sssdconfig-1.14.0-43.el7_3.4.noarch from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-client-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libpciaccess-0.13.4-2.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> 7:lvm2-libs-2.02.166-1.el7_3.2.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> python-firewall-0.4.3.2-8.el7.noarch from @anaconda/7.3 removed (updateinfo)
    --> libwbclient-4.4.4-9.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 2:microcode_ctl-2.1-16.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> kernel-tools-libs-3.10.0-514.2.2.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> libipa_hbac-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-krb5-1.14.0-43.el7_3.11.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> sssd-common-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> xfsprogs-4.5.0-9.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> policycoreutils-2.5-9.el7.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> python-pulp-common-2.8.7.5-1.el7sat.noarch from rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> sssd-krb5-common-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-utils-9.9.4-38.el7_3.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> libsemanage-2.5-5.1.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> selinux-policy-targeted-3.13.1-102.el7_3.7.noarch from @rhel-7-server-rpms removed (updateinfo)
    --> openssh-clients-6.6.1p1-33.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> libipa_hbac-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> sssd-krb5-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> 32:bind-libs-9.9.4-38.el7_3.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> pulp-rpm-handlers-2.8.7.6-1.el7sat.noarch from rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    --> samba-common-4.4.4-9.el7.noarch from @rhel-7-server-rpms removed (updateinfo)
    --> libsemanage-python-2.5-5.1.el7_3.x86_64 from rhel-7-server-rpms removed (updateinfo)
    --> firewalld-0.4.3.2-8.1.el7_3.noarch from rhel-7-server-rpms removed (updateinfo)
    --> libsemanage-2.5-4.el7.x86_64 from @anaconda/7.3 removed (updateinfo)
    --> libsss_sudo-1.14.0-43.el7_3.4.x86_64 from @rhel-7-server-rpms removed (updateinfo)
    --> python-pulp-rpm-common-2.8.7.5-1.el7sat.noarch from @rhel-7-server-satellite-tools-6.2-rpms removed (updateinfo)
    No packages needed for security; 55 packages available

Actual results:
No packages needed for security;

Expected results:
Apply installable errata

History

#1 Updated by Brad Buckingham over 1 year ago

  • Subject changed from Clients show Advisory not applicable for this system when errata is applicable to Clients show Advisory not applicable for this system when errata is applicable
  • Target version set to 169
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 169 to 178

#3 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 178 to 181

#4 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 181 to 187

#5 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 187 to 193

#6 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 193 to 196

#7 Updated by Justin Sherrill over 1 year ago

  • Subject changed from Clients show Advisory not applicable for this system when errata is applicable to Clients show Advisory not applicable for this system when errata is applicable and event count is not zero

#8 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 196 to 202

#9 Updated by Brad Buckingham over 1 year ago

  • Target version changed from 202 to 205

#10 Updated by Brad Buckingham about 1 year ago

  • Target version changed from 205 to 208

#11 Updated by Brad Buckingham about 1 year ago

  • Target version changed from 208 to 213

#12 Updated by Brad Buckingham about 1 year ago

  • Target version changed from 213 to 160

This issue may be a duplicate of http://projects.theforeman.org/issues/20280; however, let's wait a bit longer before closing it out. Also monitoring a downstream bugzilla.

Also available in: Atom PDF