Project

General

Profile

Bug #18708

view_lifecycle_environments permission does not show lifecycle environments

Added by Brad Buckingham over 2 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Category:
Lifecycle Environments
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1420511

Description of problem:

view_lifecycle_environments will not show lifecycle environments on https://katello.example.com/lifecycle_environments

How reproducible: Always
Steps to Reproduce:

1. Create additional lifecycle environments other than Library

2. Create a role with the following permissions:
(Miscellaneous) access_dashboard
Lifecycle Environment edit_lifecycle_environments, promote_or_remove_content_views_to_environments, view_lifecycle_environments
Location view_locations
Organization view_organizations

3. Assign a user to that role

4. Log in with that user and navigate to Content -> Lifecycle Environments (https://katello-test/lifecycle_environments)

Actual results:

You can see the presence of the tables showing Content Views and Content Hosts in each Lifecycle Environment, but the Clickable Content View name link is missing from the top of each, making them unable to be navigated or even discerned from each other.

Expected results:

The Lifecycle Environment's name should appear at the top of each table section with a clickable link to the actual instance of the specific Lifecycle page

Additional info:

- Adding the "create_lifecycle_environments" permission will allow the Lifecycle Environment names to show up and be clicked on.
- Also, I can still directly view a Lifecycle Environment by going to the URL directly even without the "create_lifecycle_environments" permission (i.e. https://katello-test/lifecycle_environments/5/details)

Related issues

Is duplicate of Katello - Bug #13905: Authorization issue on Lifecycle environments listClosed2016-02-25

History

#1 Updated by Brad Buckingham over 2 years ago

  • Subject changed from view_lifecycle_environments permission does not show lifecycle environments to view_lifecycle_environments permission does not show lifecycle environments
  • Target version set to 169
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Brad Buckingham over 2 years ago

  • Assignee set to Brad Buckingham

#3 Updated by Brad Buckingham over 2 years ago

  • Status changed from New to Duplicate

This issue is a duplicate of http://projects.theforeman.org/issues/13905 .

#4 Updated by Brad Buckingham over 2 years ago

  • Is duplicate of Bug #13905: Authorization issue on Lifecycle environments list added

Also available in: Atom PDF