Project

General

Profile

Bug #18721

Make sure that the UI/CLI is properly showing the error from pulp on puppet module upload

Added by David Davis over 2 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Content Uploads
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Before pulp was swallowing errors when puppet modules were being uploaded. Now with this fix, the error should be properly set on the task:

https://pulp.plan.io/issues/2512

We need to make sure that the Katello UI and hammer are displaying this message.

Steps:

1. Create a bad module (e.g. "touch blah-blah-1.2.1.tar.gz")
2. Upload it via Hammer/UI
3. Confirm that you see "Could not extract puppet module."

History

#1 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 228

#2 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 228 to 114
  • Difficulty set to easy

#3 Updated by Justin Sherrill over 1 year ago

  • Legacy Backlogs Release (now unused) changed from 114 to 284
  • Status changed from New to Resolved

This is resolved now.

#4 Updated by John Mitsch over 1 year ago

  • Legacy Backlogs Release (now unused) changed from 284 to 352

Also available in: Atom PDF