Project

General

Profile

Bug #18722

Can't edit parameter after foreman update 1.13.4 to 1.14.1

Added by L W over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Authorization
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

After updating foreman from version 1.13.4 to 1.14.1 editing of global and host parameters doesn't work any longer. It only works if a user is administrator and it doesn't even work when a user has the following role permissions: "Parameter - destroy_params, view_params, edit_params, create_params". A user with the "Parameter" permission can add new parameter, but is not able to enter some value.

role_filters.png View role_filters.png 60.3 KB L W, 02/28/2017 09:04 AM
new_host_parameter.png View new_host_parameter.png 21.9 KB L W, 02/28/2017 09:04 AM
foreman_debug.log foreman_debug.log 58.5 KB L W, 02/28/2017 09:48 AM
Role filters New host parameter

Related issues

Related to Foreman - Refactor #16739: Unify common parameters permissions (global, os, domain)Closed2016-09-29

Associated revisions

Revision 4017d259 (diff)
Added by Marek Hulán over 2 years ago

Fixes #18722 - fix host parameters in host form

Revision ffb2043f (diff)
Added by Marek Hulán over 2 years ago

Fixes #18722 - fix host parameters in host form

(cherry picked from commit 4017d259e70d2d3204fd8abe2cd7066f557d0eac)

History

#1 Updated by Dominic Cleal over 2 years ago

  • Category set to Authorization
  • Legacy Backlogs Release (now unused) set to 221

#2 Updated by Dominic Cleal over 2 years ago

  • Related to Refactor #16739: Unify common parameters permissions (global, os, domain) added

#3 Updated by Dominic Cleal over 2 years ago

It may help to attach production.log while loading the new host page, while debugging, sql and permissions logging is enabled (https://theforeman.org/manuals/1.14/index.html#7.2Debugging).

#4 Updated by L W over 2 years ago

Debug log added

#5 Updated by Dominic Cleal over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 221 to 227

#6 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Marek Hulán
  • Pull request https://github.com/theforeman/foreman/pull/4355 added

#7 Updated by Marek Hulán over 2 years ago

I was able to reproduce and sent a fix, see a linked Pull request. It would help us if you could test it and verify it fixes the problem for you. If it would be possible, please share your findings here or in the PR.

#8 Updated by L W over 2 years ago

Marek Hulán wrote:

I was able to reproduce and sent a fix, see a linked Pull request. It would help us if you could test it and verify it fixes the problem for you. If it would be possible, please share your findings here or in the PR.

Bugfix works for me. Thanks a lot!

#9 Updated by Anonymous over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF