Project

General

Profile

Bug #18733

External Registry search falls back to Docker Hub

Added by Sebastian Gräßl over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Plugin (foreman_docker)
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

When no registry is selected the Hub is searched on the External registry tab when choosing an image for creating a new container.

Steps to reproduce:

1. In Satellite UI, create a new container (Containers > New container)
2. In the Image stage, select External registry
3. DO NOT select a registry from the drop-down menu. Search for an image -- type "rhel" to the Search field and click the looking glass button.
4. Results from the Docker Hub are listed -- see attached screenshot

This can lead to a potentially dangerous confusion, user might pull an image from the Docker Hub thinking it comes from a pre-configured external repository (e.g. registry.access.redhat.com).

Expected results:

UI should display a warning, something like "Please select a registry"

Associated revisions

Revision f02a9ce2 (diff)
Added by Sebastian Gräßl over 5 years ago

Fixes #18733 - Prevent fallback to Docker Hub on registry search

When searching for an external registry the search would show
results from Docker Hub due to it searching via the compute
resource.

By using a registry parameter to indicate which search tab is
active this gets prevented on the backend as well as on the
client by not searching when no registry is selected.

Revision f02a9ce2 (diff)
Added by Sebastian Gräßl over 5 years ago

Fixes #18733 - Prevent fallback to Docker Hub on registry search

When searching for an external registry the search would show
results from Docker Hub due to it searching via the compute
resource.

By using a registry parameter to indicate which search tab is
active this gets prevented on the backend as well as on the
client by not searching when no registry is selected.

History

#1 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-docker/pull/185 added

#2 Updated by Anonymous over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF