Project

General

Profile

Bug #18739

Hammer host list output should display hostgroup_title

Added by Daniel Lobato Garcia over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
High
Category:
Hosts
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1427554
Description of problem:

changes in hammer host list output since upgrade from 6.1 to 6.2

Version-Release number of selected component (if applicable):
Satellite 6.2.7

How reproducible:
1) Have a satellite 6.1,
2) Run “$hammer host list” and check HostGroup field, you can find full HostGroup name
3) Upgrade the satellite to 6.2.7,
4) now run “$hammer host list” and check HostGroup field which will only display last part of HostGroup.

Actual results:

Only last part of the HostGroup listed

Expected results:

Full HostGroup has to be listed as usual after an upgrade

Additional info:
Hammer host list used to list full hostgroup like so:

-----|--------------------------------|------------------|-------------------------------------|---------------|------------------
ID | NAME | OPERATING SYSTEM | HOST GROUP | IP | MAC
-----|--------------------------------|------------------|-------------------------------------|---------------|------------------
1075 | dhcptest.phx.aexp.com | RHEL Server 6.8 | TRCW/E2/Virt-R6/Unassigned | xx.xx.xx.118 | 00:50:56:xx:xx:xx

Since the upgrade it just shows the last portion of the host group name:

-----|-----------------------------------------|------------------|-------------------|-----------------|------------------
ID | NAME | OPERATING SYSTEM | HOST GROUP | IP | MAC
-----|-----------------------------------------|------------------|-------------------|-----------------|------------------
1075 | dhcptest.phx.aexp.com | RHEL Server 6.8 | Unassigned | xx.xx.xxx.118 | 00:50:56:xx:xx:xx

Associated revisions

Revision a5e4a00e (diff)
Added by Daniel Lobato García over 3 years ago

Fixes #18739 - Display hostgroup title on host actions

Before this patch, host list was displaying only the leaf of the hostgroup tree.
E.g: 'base/hostgroup1' displayed as 'hostgroup1' in the Host list table.

After this patch, 'base/hostgroup1' is displayed, which is more useful
than the leaf (which could be the same for different trees). The same
thing has been fixed for Host info.

History

#1 Updated by Daniel Lobato Garcia over 3 years ago

  • Subject changed from changes in hammer host list output since upgrade from 6.1 to 6.2 to Hammer host list output should display hostgroup_title

#2 Updated by Daniel Lobato Garcia over 3 years ago

  • Project changed from Foreman to Hammer CLI

#3 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Daniel Lobato Garcia
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/287 added

#4 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Tomáš Strachota over 3 years ago

  • Category set to Hosts
  • Legacy Backlogs Release (now unused) set to 234

Also available in: Atom PDF