Project

General

Profile

Bug #18759

registration with activation key fails with 'Couldn't find Domain with 'id'=1 [WHERE (1=0)]'

Added by Justin Sherrill about 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Urgent
Category:
Hosts
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

This is causing pipeline breakges.

Currently if there is a domain that is created, but not in any org or location, and a host tries to register, it will fail. This because the domain is no longer visible.


Related issues

Is duplicate of Katello - Bug #18729: Bats registration fails on nightlyDuplicate2017-02-28

Associated revisions

Revision 028b832a (diff)
Added by Justin Sherrill about 2 years ago

Fixes #18759 - use admin user for fact import

History

#1 Updated by Justin Sherrill about 2 years ago

To reproduce,

1) create a domain as the admin user, do NOT assign it to an org or location
2) register a host using that domain with an activation key

#2 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6644 added

#3 Updated by Eric Helms about 2 years ago

  • Is duplicate of Bug #18729: Bats registration fails on nightly added

#4 Updated by Eric Helms about 2 years ago

  • Priority changed from Normal to Urgent

#5 Updated by Justin Sherrill about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF