Project

General

Profile

Bug #18790

[Satellite 6.2.7] Per-page and page options do nothing on hammer role filters (--per-page --page)

Added by Marek Hulán over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Users and roles
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1428516

Description of problem:

While listing role's filter using hammer cli results in fixed output even passing --per-page and --page options

Version-Release number of selected component (if applicable):

satellite-cli-6.2.7-1.0.el7sat.noarch
foreman-1.11.0.65-1.el7sat.noarch
tfm-rubygem-hammer_cli-0.5.1.12-1.el7sat.noarch

same problems on current develop checkout

How reproducible:
100 %

Steps to Reproduce:

#hammer shell

hammer> role filters --name Manager --per-page 5
(or)
hammer> role filters --name Manager --per-page 10 --page 2

Actual results:

hammer> role filters --name Manager --per-page 4
---|----------------------|--------|------------|---------|---------------------------------------------------------------------------------
ID | RESOURCE TYPE | SEARCH | UNLIMITED? | ROLE | PERMISSIONS
---|----------------------|--------|------------|---------|---------------------------------------------------------------------------------
7 | Architecture | none | yes | Manager | view_architectures, create_architectures, edit_architectures, destroy_archite...
8 | Audit | none | yes | Manager | view_audit_logs
9 | AuthSourceLdap | none | yes | Manager | view_authenticators, create_authenticators, edit_authenticators, destroy_auth...
10 | Bookmark | none | yes | Manager | view_bookmarks, create_bookmarks, edit_bookmarks, destroy_bookmarks
11 | CommonParameter | none | yes | Manager | view_globals, create_globals, edit_globals, destroy_globals
12 | ComputeResource | none | yes | Manager | view_compute_resources, create_compute_resources, edit_compute_resources, des...
13 | (Miscellaneous) | none | yes | Manager | access_dashboard, view_plugins, access_settings, view_statistics, view_tasks
14 | Domain | none | yes | Manager | view_domains, create_domains, edit_domains, destroy_domains
15 | Environment | none | yes | Manager | view_environments, create_environments, edit_environments, destroy_environmen...
16 | FactValue | none | yes | Manager | view_facts, upload_facts
17 | HostClass | none | yes | Manager | edit_classes
18 | Hostgroup | none | yes | Manager | view_hostgroups, create_hostgroups, edit_hostgroups, destroy_hostgroups
19 | Host | none | yes | Manager | view_hosts, create_hosts, edit_hosts, destroy_hosts, build_hosts, power_hosts...
20 | Image | none | yes | Manager | view_images, create_images, edit_images, destroy_images
21 | Location | none | yes | Manager | view_locations, create_locations, edit_locations, destroy_locations, assign_l...
22 | PuppetclassLookupKey | none | yes | Manager | view_external_parameters, create_external_parameters, edit_external_parameter...
23 | MailNotification | none | yes | Manager | view_mail_notifications
24 | Medium | none | yes | Manager | view_media, create_media, edit_media, destroy_media
25 | Model | none | yes | Manager | view_models, create_models, edit_models, destroy_models
26 | Operatingsystem | none | yes | Manager | view_operatingsystems, create_operatingsystems, edit_operatingsystems, destro...
---|----------------------|--------|------------|---------|---------------------------------------------------------------------------------
Page 1 of 2 (use --page and --per-page for navigation)

Expected results:

hammer> role filters --name Manager --per-page 5
---|----------------------|--------|------------|---------|---------------------------------------------------------------------------------
ID | RESOURCE TYPE | SEARCH | UNLIMITED? | ROLE | PERMISSIONS
---|----------------------|--------|------------|---------|---------------------------------------------------------------------------------
7 | Architecture | none | yes | Manager | view_architectures, create_architectures, edit_architectures, destroy_archite...
8 | Audit | none | yes | Manager | view_audit_logs
9 | AuthSourceLdap | none | yes | Manager | view_authenticators, create_authenticators, edit_authenticators, destroy_auth...
10 | Bookmark | none | yes | Manager | view_bookmarks, create_bookmarks, edit_bookmarks, destroy_bookmarks
11 | CommonParameter | none | yes | Manager | view_globals, create_globals, edit_globals, destroy_globals
---|----------------------|--------|------------|---------|---------------------------------------------------------------------------------
Page 1 of 2 (use --page and --per-page for navigation)

Additional info:

The problem is in the fact that request_params for filter command are hardcoded to role id


Related issues

Has duplicate Hammer CLI - Bug #17325: hammer role filters show always only first 20 recordsDuplicate2016-11-14

Associated revisions

Revision 30cdfece (diff)
Added by Marek Hulán over 3 years ago

Fixes #18790 - respect original request_params

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Marek Hulán
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/288 added

#2 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Tomáš Strachota over 3 years ago

  • Subject changed from [Satellite 6.2.7] Per-page and page options do nothing on hammer role filters (--per-page --page) to [Satellite 6.2.7] Per-page and page options do nothing on hammer role filters (--per-page --page)
  • Legacy Backlogs Release (now unused) set to 234

#4 Updated by Dominic Cleal about 3 years ago

  • Has duplicate Bug #17325: hammer role filters show always only first 20 records added

Also available in: Atom PDF