Project

General

Profile

Bug #18794

Not all puppet modules showing up when adding them to a content view

Added by Josh Pavel about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

The following is on a Katello 3.3, Foreman 1.14.2 install

1.) I have a puppet module repo synced with the public puppet forge. It contains 4840 puppet modules.

2.) Verified - on the system:
Web UI: Public Puppet Forge puppet Success 19 minutes ago 4840 Puppet Modules
Shell:
[root@foreman-01 releases]# pwd
/var/lib/pulp/published/puppet/http/repos/nuance_mobility-Puppet_Modules-Public_Puppet_Forge/system/releases
[root@foreman-01 releases]# find ./* -name "*.gz" | wc -l
4840

3.) New content view --> Puppet Modules --> Add New Module
Showing 40 of 2961 (2961 Total)
Also, "search" doesn't reveal all the modules.
E.g., theforeman-foreman_scap_client-0.3.13.tar.gz (search OR scroll down reveals nothing)
ls --la /var/lib/pulp/content/units/puppet_module/43/8035d207ff451a6c842f05007cb07d84a77a3f70cdbf2f032eb1c82cb7d798/theforeman-foreman_scap_client-0.3.13.tar.gz
--rw-r--r-- 1 apache apache 11285 Feb 23 19:27 /var/lib/pulp/content/units/puppet_module/43/8035d207ff451a6c842f05007cb07d84a77a3f70cdbf2f032eb1c82cb7d798/theforeman-foreman_scap_client-0.3.13.tar.gz

It may or may not be related, but my search bar is also incorrect (maybe just a UI issue - see screen shot)

Screen Shot 2017-03-03 at 9.07.03 PM.png View Screen Shot 2017-03-03 at 9.07.03 PM.png 15.1 KB Missing puppet modules and messed up search box Josh Pavel, 03/03/2017 09:07 PM
Screen Shot 2017-03-03 at 9.11.26 PM.png View Screen Shot 2017-03-03 at 9.11.26 PM.png 59.7 KB Josh Pavel, 03/03/2017 09:11 PM
Screen%20shot%202017 03 03%20at%209.07.03%20pm Screen%20shot%202017 03 03%20at%209.11.26%20pm

Related issues

Is duplicate of Katello - Bug #17930: unable to add a puppet module from GUIClosed2017-01-04

History

#2 Updated by John Mitsch about 5 years ago

  • Is duplicate of Bug #17930: unable to add a puppet module from GUI added

#3 Updated by John Mitsch about 5 years ago

  • Status changed from New to Duplicate

#4 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF