Project

General

Profile

Bug #18820

Empty name and Version in Composite Content View (WebUI)

Added by Klaas D over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hi,
after upgrading from katello 3.2 to 3.3 the composite content view is not showing the correct names of the content views it includes, see attached screenshot. If I create a new one it works fine, if I look at it though command line (hammer) it shows correct components.

Greetings
Klaas

Associated revisions

Revision 798a84b8 (diff)
Added by Justin Sherrill over 5 years ago

Fixes #18820 - fill in CV id on components

during the migration to add latest to component
content views, the content view id field is used
but not populated during the migration.

History

#1 Updated by Justin Sherrill over 5 years ago

  • Target version set to 178
  • Legacy Backlogs Release (now unused) set to 226
  • Assignee set to Justin Sherrill

#2 Updated by The Foreman Bot over 5 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6690 added

#3 Updated by Justin Sherrill over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Klaas D over 5 years ago

I tested it on my 3.3.1 install, worked as expected thanks Justin Sherrill

#5 Updated by Jason Nance about 5 years ago

Is this data lost or just not populated? Meaning, if I'm on 3.3.1 now with this bug and then upgrade to 3.3.2 when it is released with the fix will the magic make it work or do I need to go from one working version (3.2.x) to another working version?

Also available in: Atom PDF