Project

General

Profile

Bug #18826

User without email encounters UrlGenerationError

Added by David Davis over 1 year ago. Updated 28 days ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

1. Create a new user with Viewer role but do not set email
2. Log into foreman. It should immediately direct you to user edit
3. Click a link to go to a Katello page (e.g. activation keys)
4. Observe error (see screenshot)


Related issues

Is duplicate of Foreman - Bug #19529: Unable to access plugin pages when user email is not providedClosed2017-05-12

History

#1 Updated by Kavita Gaikwad over 1 year ago

  • Assignee set to Kavita Gaikwad
  • Target version set to 1.15.6

#2 Updated by Eric Helms over 1 year ago

  • Legacy Backlogs Release (now unused) set to 114

#3 Updated by Kavita Gaikwad about 1 year ago

  • Project changed from Katello to Foreman
  • Legacy Backlogs Release (now unused) deleted (114)

#4 Updated by Kavita Gaikwad about 1 year ago

  • Pull request https://github.com/theforeman/foreman/pull/4670 added

#5 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing

#6 Updated by Kavita Gaikwad about 1 year ago

  • Target version changed from 1.15.6 to 1.17.0-RC1

#7 Updated by Kavita Gaikwad about 1 year ago

  • Target version changed from 1.17.0-RC1 to 1.17.0

#8 Updated by David Davis about 1 year ago

  • Status changed from Ready For Testing to Duplicate

#9 Updated by David Davis about 1 year ago

  • Is duplicate of Bug #19529: Unable to access plugin pages when user email is not provided added

#10 Updated by Kavita Gaikwad 11 months ago

  • Target version changed from 1.17.0 to 216

#11 Updated by Ewoud Kohl van Wijngaarden 28 days ago

  • Triaged set to No
  • Target version deleted (1.18.0)

Also available in: Atom PDF