Project

General

Profile

Bug #18848

publishing a puppet module in a content view errors

Added by John Mitsch about 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

To reproduce add a puppet module to a content view and publish

cvpe_docker_name.txt cvpe_docker_name.txt 20.7 KB John Mitsch, 03/08/2017 03:47 PM

Associated revisions

Revision 7dd24a1f (diff)
Added by John Mitsch about 2 years ago

Fixes #18848 - Check for docker repo when calling container_repo
sitory_name

This method doesn't exist for content view puppet environments,
which are created on the capsule the same way repositories are.
Since docker repos only need container_repository_name, we can
only set this for docker repos and have the others be nil.

History

#1 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6661 added

#2 Updated by John Mitsch about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF