Project

General

Profile

Actions

Bug #18872

closed

Katello with custom certificate. Pulp restclient error.

Added by Stanislav Mikhalevich about 7 years ago. Updated almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

If katello installed with custom certificate pulp service don't work.

SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed


Related issues 1 (0 open1 closed)

Is duplicate of Katello - Bug #18730: Upgrading to katello 3.3 from 3.2 breaks pulp certificate verificationClosed02/28/2017Actions
Actions #1

Updated by Stanislav Mikhalevich about 7 years ago

  • Category set to Repositories
Actions #2

Updated by Stanislav Mikhalevich about 7 years ago

Example error:

@2017-03-12 19:54:28 7cde643b [app] [I] Started GET "/katello/sync_management" for 192.168.100.1 at 2017-03-12 19:54:28 +0300
2017-03-12 19:54:28 7cde643b [app] [I] Processing by Katello::SyncManagementController#index as HTML
2017-03-12 19:54:28 7cde643b [katello/pulp_rest] [E] RestClient.post "https://foreman.local/pulp/api/v2/repositories/search/", "{\"criteria\":{\"filters\":{\"id\":{\"$in\":[]}}}}", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Content-Length"=>"42", "accept"=>"application/json", "content_type"=>"application/json" |
2017-03-12 19:54:28 7cde643b [app] [I] Completed 500 Internal Server Error in 95ms (ActiveRecord: 6.7ms)
2017-03-12 19:54:28 7cde643b [app] [F] | RestClient::SSLCertificateNotVerified (SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed): | katello (3.3.0.1) app/models/katello/glue/pulp/repos.rb:53:in `prepopulate!' | katello (3.3.0.1) app/helpers/katello/sync_management_helper.rb:38:in `collect_repos' | katello (3.3.0.1) app/controllers/katello/sync_management_controller.rb:27:in `index' | app/controllers/concerns/application_shared.rb:14:in `set_timezone' | lib/middleware/catch_json_parse_errors.rb:8:in `call' | lib/middleware/tagged_logging.rb:18:in `call' | |
@

Actions #3

Updated by Stanislav Mikhalevich about 7 years ago

  • Subject changed from Katello with custom certificate. Pulp error. to Katello with custom certificate. Pulp restclient error.
Actions #4

Updated by Stanislav Mikhalevich about 7 years ago

  • translation missing: en.field_release set to 219
Actions #5

Updated by Justin Sherrill about 7 years ago

  • Status changed from New to Duplicate

Duplicate of issue 18730

Actions #6

Updated by Justin Sherrill about 7 years ago

  • Is duplicate of Bug #18730: Upgrading to katello 3.3 from 3.2 breaks pulp certificate verification added
Actions

Also available in: Atom PDF