Project

General

Profile

Bug #18883

Passenger RackApp out of memory

Added by Denis Müller over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

While filtering for specifig host on "all hosts" page, this task takes minutes till it would be killed by the kernel, see screenshot.

[root@theforeman ~]# rpm -qa | grep -i katello
katello-service-3.3.0-3.el7.noarch
katello-3.3.0-3.el7.noarch
foreman-installer-katello-3.3.0-5.el7.noarch
katello-default-ca-1.0-1.noarch
katello-installer-base-3.3.0-5.el7.noarch
katello-common-3.3.0-3.el7.noarch
tfm-rubygem-katello_ostree-3.3.0.1-1.el7.noarch
katello-repos-3.3.0-2.el7.noarch
katello-ca-consumer-theforeman.nodes.rto.de-1.0-3.noarch
python-urllib3-1.10.2-2.katello.el7.noarch
katello-selinux-3.0.2-1.el7.noarch
katello-agent-2.9.1-1.el7.noarch
katello-client-bootstrap-1.2.2-1.el7.noarch
katello-server-ca-1.0-1.noarch
katello-certs-tools-2.4.0-1.el7.noarch
tfm-rubygem-hammer_cli_katello-0.3.0-1.el7.noarch
pulp-katello-1.0.2-1.el7.noarch
katello-debug-3.3.0-3.el7.noarch
tfm-rubygem-katello-3.3.0.1-1.el7.noarch
katello-agent-fact-plugin-2.9.1-1.el7.noarch

[root@theforeman ~]# rpm -qa | grep -i passenger
tfm-rubygem-passenger-native-libs-4.0.18-9.11.el7.x86_64
tfm-rubygem-passenger-native-4.0.18-9.11.el7.x86_64
mod_passenger-4.0.53-4.el7.x86_64
tfm-rubygem-passenger-4.0.18-9.11.el7.x86_64
passenger-4.0.53-4.el7.x86_6


Related issues

Has duplicate Katello - Bug #18909: Host searches slow and consume excessive amounts of ramDuplicate2017-03-15
Is duplicate of Katello - Bug #19461: [regression] host search by organization never finishes but causes mem.leak in foreman processClosed2017-05-04

History

#1 Updated by Justin Sherrill over 5 years ago

  • Category set to Hosts
  • Priority changed from Normal to High
  • Legacy Backlogs Release (now unused) changed from 219 to 226

#2 Updated by Justin Sherrill over 5 years ago

  • Has duplicate Bug #18909: Host searches slow and consume excessive amounts of ram added

#3 Updated by Klaas D about 5 years ago

#4 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 226 to 228

#5 Updated by Justin Sherrill about 5 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 228 to 226

I do think this is a duplicate of http://projects.theforeman.org/issues/19461

Please reopen if it is not resolved in 3.3.2 or 3.4.0. Thanks

#6 Updated by Justin Sherrill about 5 years ago

  • Is duplicate of Bug #19461: [regression] host search by organization never finishes but causes mem.leak in foreman process added

Also available in: Atom PDF