Project

General

Profile

Bug #18924

Unable to destroy content view

Added by John Mitsch about 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1418582

Description of problem:
Content view destroy task(the id of the task is- 2b5f8f01-f53b-4611-ad30-f115cca74b1a and its details are mentioned in the task exported in the file-
tmp/task-export20161228-10341-10cfe3e/2b5f8f01-f53b-4611-ad30-f115cca74b1a.html) is failing with error-

RestClient::ResourceNotFound

404 Resource Not Found

One of a sub task Actions::Pulp::Repository::Destroy is complaining for repo-
LME-Functional_Testing-TST_-_Ken_-_RHEL7

This repo does not exist in pulp db as well as in foreman db's katello_repositories table(in an attempt to resolve another issue, these repo has been removed).

Now original issue which was reported in the case is resolved, we need to remove the old CV.

Now when we try to delete the CV as-

Katello::ContentView.where("name = ?", "<cv-name>").destroy_all

is failing with the below error-

ActiveRecord::ActiveRecordError: can not update on a new record object

OR

NoMethodError: undefined method `extensions' for nil:NilClass

The CV remains visible on the katello webUI.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
CV cant be deleted

Expected results:

CV should be removed and not be visible on the webUI
Additional info:


Related issues

Is duplicate of Katello - Bug #15567: Katello 3.0 - Failed to delete a content viewResolved2016-07-03

History

#1 Updated by John Mitsch about 5 years ago

  • Subject changed from Unable to destroy content view to Unable to destroy content view
  • Target version set to 178

#2 Updated by John Mitsch about 5 years ago

  • Is duplicate of Bug #15567: Katello 3.0 - Failed to delete a content view added

#3 Updated by John Mitsch about 5 years ago

  • Status changed from New to Duplicate

#4 Updated by Eric Helms about 5 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF