Project

General

Profile

Bug #18941

Repo sync is completing successfully, but is not finding new packages that are in the repo

Added by Leah Fisher about 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Upon upgrade from 3.2 to 3.3, the sync was no longer updating properly. Since I was syncing to a local url, I was able to look at my apache logs and see that there was no request for repodata in my apache logs. I'm unsure why it was completing successfully.

Updating the link to somethat that would error and changing it back seemed to solve the problem. I also had to run
mongo pulp_database --eval 'db.repo_importers.update({"scratchpad": {$ne: null}}, {$set: {"scratchpad.repomd_revision": null}}, {"multi":true})' since the repo metadata date locally got update.

History

#1 Updated by Eric Helms about 5 years ago

  • Status changed from New to Needs design

#2 Updated by John Mitsch about 5 years ago

  • Category set to Repositories
  • Assignee set to John Mitsch
  • Legacy Backlogs Release (now unused) set to 228

#3 Updated by John Mitsch about 5 years ago

  • Target version set to 160

#4 Updated by Justin Sherrill about 5 years ago

I believe this may have been resolved by http://projects.theforeman.org/issues/18816 where by the feed url was being updated to localhost.

#5 Updated by Justin Sherrill about 5 years ago

Are you able to reproduce this on 3.3.1 or 3.4 rc?

#6 Updated by Justin Sherrill about 5 years ago

  • Status changed from Needs design to Need more information
  • Legacy Backlogs Release (now unused) changed from 228 to 166

#7 Updated by Justin Sherrill almost 5 years ago

  • Status changed from Need more information to Rejected

Closing this as we believe it is now resolved, please reopen if you can still reproduce!

Also available in: Atom PDF