Project

General

Profile

Bug #18983

Composite Content View shows incorrect total number of included repos

Added by Brad Buckingham about 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Content Views
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1431778

Description of problem:

Composite content views show an incorrect number of total included repositories on the Content > Content Views page.

For example: I have a CCV which includes three CVS; each CV has two repos. When I navigate to Content > Content Views, the CCV shows that the view contains 12 repos, when it really only contains 6 repos.

Steps to Reproduce:
1. Create a CCV comprised of multiple CVs
2. Publish a new version of the CCV
3. Navigate to Content > Content Views and check the total repo count for the CCV, comparing it to the actual total number of repos for each included CV.

Actual results:

CCV repo total shows about double the actual number of repos in the CCV.

Expected results:

CCV repo total should be accurate.

Associated revisions

Revision 3166c7cf (diff)
Added by Brad Buckingham about 2 years ago

fixes #18983 - correct composite view 'component repositories'

Simple change to correctly reflect the repositories that are
part of a composite content view.

Example scenario:

1. component version 2.0 is associated with the composite
2. the component version (2.0) has 4 repositories associated with it
3. the component version (2.0) has been promoted to 3 lifecycle
environments (dev, test & prod)

Prior to the change, the result would be:
- 4 repos to represent the 2.0 version (archived repos)
- 4 repos in dev
- 4 repos in test
- 4 repos in prod =
16 repos

The correct behavior should be to only returned the archived
repos (4), since that is what is associated to the composite.

History

#1 Updated by Brad Buckingham about 2 years ago

  • Subject changed from Composite Content View shows incorrect total number of included repos to Composite Content View shows incorrect total number of included repos
  • Target version set to 178
  • Legacy Backlogs Release (now unused) set to 228
  • Difficulty set to easy

#2 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6694 added

#3 Updated by Brad Buckingham about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Eric Helms about 2 years ago

  • Legacy Backlogs Release (now unused) changed from 228 to 211

Also available in: Atom PDF