Project

General

Profile

Bug #1899

Can't create new ovirt VM due to http 302 error

Added by viet nguyen almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

If ovirt rest api requires https and Compute URL is set to http VM creation will fail

Failed to save: Failed to create a compute jon-rhev (oVirt) instance zzz: 302 Found
/usr/lib/ruby/gems/1.8/gems/rbovirt-0.0.12/lib/rbovirt.rb:131:in `handle_fault'
/usr/lib/ruby/gems/1.8/gems/rbovirt-0.0.12/lib/rbovirt.rb:77:in `http_post'
/usr/lib/ruby/gems/1.8/gems/rbovirt-0.0.12/lib/client/vm_api.rb:18:in `create_vm'
/usr/lib/ruby/gems/1.8/gems/fog-1.6.0/lib/fog/ovirt/requests/compute/create_vm.rb:7:in `create_vm'
/usr/lib/ruby/gems/1.8/gems/fog-1.6.0/lib/fog/ovirt/models/compute/server.rb:122:in `save'


Related issues

Related to Foreman - Bug #2061: HTTPS URL for oVirt shouldn't be mandatoryClosed2012-12-19

Associated revisions

Revision dcb32cd5 (diff)
Added by Dominic Cleal over 9 years ago

fixes #1899 require HTTPS URL for oVirt API, now HTTPS-only

History

#1 Updated by Greg Sutcliffe over 9 years ago

  • Target version set to Bug scrub

#2 Updated by Dominic Cleal over 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

#3 Updated by Dominic Cleal over 9 years ago

  • Category set to Compute resources

#4 Updated by Ohad Levy over 9 years ago

  • Target version changed from Bug scrub to 1.1

#5 Updated by Dominic Cleal over 9 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF