Project

General

Profile

Bug #19078

UI is malformed for Activation Key Subscriptions

Added by Josh Pavel over 5 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Foreman 1.14.2
Katello 3.3.1

Issue visible in FireFox 52.0.2 and Chrome 56.0.2924.87

Browse to Content -> Activation Keys -> [select any] -> Subscriptions

Data is misaligned and content is missing (see screenshot).

Possibly related:

Browse to Hosts -> Content Hosts -> [select host] -> Subscriptions

Data is aligned in vertical column (see screenshot)

Screen Shot 2017-03-29 at 3.57.24 PM.png View Screen Shot 2017-03-29 at 3.57.24 PM.png 186 KB Content Host Subscription UI Josh Pavel, 03/29/2017 03:58 PM
Screen Shot 2017-03-29 at 3.52.37 PM.png View Screen Shot 2017-03-29 at 3.52.37 PM.png 134 KB Activation Key Subscription UI Josh Pavel, 03/29/2017 03:59 PM
subscription_content_host.PNG View subscription_content_host.PNG 10.4 KB Javier Vela, 05/04/2017 05:36 AM
subscription_activation_key.PNG View subscription_activation_key.PNG 9.21 KB Javier Vela, 05/04/2017 05:36 AM
Screen%20shot%202017 03 29%20at%203.57.24%20pm Screen%20shot%202017 03 29%20at%203.52.37%20pm Subscription content host Subscription activation key

Related issues

Has duplicate Katello - Bug #19218: Colums width in Subscription for Content hostDuplicate2017-04-07
Is duplicate of Katello - Bug #18803: Subscription list inside a Content Host only showing one character per lineDuplicate2017-03-06
Is duplicate of Katello - Bug #18699: Content host add/remove subscription lists columns span multiple column headersClosed2017-02-27

History

#1 Updated by Eric Helms about 5 years ago

  • Assignee set to Walden Raines
  • Legacy Backlogs Release (now unused) set to 226

#2 Updated by Ondřej Levý about 5 years ago

  • Has duplicate Bug #19218: Colums width in Subscription for Content host added

#3 Updated by Klaas D about 5 years ago

  • Is duplicate of Bug #18803: Subscription list inside a Content Host only showing one character per line added

#4 Updated by Klaas D about 5 years ago

  • Is duplicate of Bug #18699: Content host add/remove subscription lists columns span multiple column headers added

#5 Updated by Javier Vela about 5 years ago

The pull request https://github.com/Katello/katello/pull/6636 is not solving the issue. I have just upgraded from 3.2 to 3.3 and I have both problems:
UI malformed on activation keys. Name is not shown.
UI malformed on content hosts when list subscriptions. Name is shown aligned in vertical. When I click on add subscriptions, the UI is OK.

I'm attaching two screenshots with the results.

I have checked the the content of the html templates is the same as in the pull request.

Regards

#6 Updated by Justin Sherrill about 5 years ago

  • Legacy Backlogs Release (now unused) changed from 226 to 228

#7 Updated by Justin Sherrill about 5 years ago

  • Status changed from New to Closed

#8 Updated by Justin Sherrill about 5 years ago

  • Status changed from Closed to Duplicate
  • Legacy Backlogs Release (now unused) changed from 228 to 226

This should be fixed in 3.3.2

Also available in: Atom PDF