Project

General

Profile

Bug #19183

Ensure that satellite-clone hammer script is tested

Added by John Mitsch about 2 years ago. Updated 10 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

In satellite-clone we use a hammer script to disassociate capsules. If we can get testing of these hammer commands it would help to prevent breakages in our script.

The script can be found here:
https://github.com/RedHatSatellite/satellite-clone/blob/master/roles/satellite-clone/files/disassociate_capsules.rb

The commands we use are:
capsule list
capsule content lifecycle-environments
capsule info
capsule content remove-lifecycle-environment
capsule content add-lifecycle-environment


Related issues

Is duplicate of Katello - Bug #19184: Ensure that satellite-clone hammer script is testedClosed2017-04-05

History

#1 Updated by Andrew Kofink about 2 years ago

  • Assignee set to Andrew Kofink
  • Target version set to 181

This issue tracks hammer-cli-foreman `capsule list` and `capsule info` tests only. http://projects.theforeman.org/issues/19184 is for all the `capsule content` commands in hammer-cli-katello.

#2 Updated by Dominic Cleal about 2 years ago

  • Project changed from Hammer CLI to Katello

#3 Updated by Andrew Kofink about 2 years ago

  • Project changed from Katello to Hammer CLI

Changing this back to Foreman. This issue tracks the `hammer capsule info|list` commands, which are a part of hammer-cli-foreman. I created #19184 for the `hammer capsule content ...` commands in Katello.

#4 Updated by Dominic Cleal about 2 years ago

  • Status changed from New to Need more information

hammer-cli-foreman doesn't have any "capsule" commands, can you double-check please? The term is a Katello one, I believe.

#5 Updated by Andrew Kofink about 2 years ago

  • Project changed from Hammer CLI to Katello
  • Status changed from Need more information to Duplicate
  • Target version deleted (181)
  • Legacy Backlogs Release (now unused) set to 166

Ah, gotcha. I'll close this one and use the other issue to track all the commands. Sorry about the confusion.

#6 Updated by Andrew Kofink about 2 years ago

  • Is duplicate of Bug #19184: Ensure that satellite-clone hammer script is tested added

#7 Updated by Andrew Kofink almost 2 years ago

  • Assignee deleted (Andrew Kofink)

Also available in: Atom PDF