Project

General

Profile

Bug #19211

UUID is not set on a ContentViewPuppetModule

Added by Andrew Kofink about 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1439927
Description of problem:
UUID is used to link a ContentViewPuppetModule to a PuppetModule in the database, but it is not set when you add a puppet module to a content view.

Version-Release number of selected component (if applicable):
6.2.8 and nightly
How reproducible:
Always
Steps to Reproduce:
1. Create a product
2. Create a puppet module repo
3. Upload a puppet module to the new repo (i.e. https://forge.puppet.com/v3/files/puppetlabs-stdlib-4.16.0.tar.gz)
4. Create a content view
5. Add your puppet module to the content view
Actual results:
The ContentViewPuppetModule object has a nil uuid
Expected results:
The ContentViewPuppetModule object has the uuid set to the PuppetModule's uuid
Additional info:
The UUID is on the ContentViewPuppetModule to enable access to the PuppetModule. i.e. content_view_puppet_module.puppet_module will give you the PuppetModule object. Otherwise, it will return nil.

History

#1 Updated by Andrew Kofink about 5 years ago

  • Subject changed from UUID is not set on a ContentViewPuppetModule to UUID is not set on a ContentViewPuppetModule

Found upstream/master as well.

#2 Updated by John Mitsch about 5 years ago

  • Assignee set to Andrew Kofink
  • Legacy Backlogs Release (now unused) set to 211

#3 Updated by Andrew Kofink about 5 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) changed from 211 to 166

This is actually not a bug. The UUID is not set when the 'latest' puppet module version is selected.

Also available in: Atom PDF