Project

General

Profile

Bug #19237

pulp_data.tar is often corrupted

Added by John Mitsch about 5 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Backup & Restore
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Often when untaring a large (100+ GB) pulp_data.tar file, I get this error:

"tar: Unexpected EOF in archive\ntar: Error is not recoverable: exiting now"

Using this command to untar: tar --selinux --overwrite -xf {{ backup_dir }}/pulp_data.tar --exclude=var/lib/pulp/katello-export -C /

This may have something to do with backups being created on sshfs-mounted directories, though I'm unsure of the root cause of this.

Maybe there is a way we can check for a corrupted pulp_data.tar file after creation?

History

#1 Updated by John Mitsch about 5 years ago

  • Assignee set to John Mitsch
  • Legacy Backlogs Release (now unused) set to 114

#2 Updated by Justin Sherrill almost 4 years ago

  • Triaged set to No
  • Target version set to Katello Recycle Bin
  • Status changed from New to Rejected

Also available in: Atom PDF