Project

General

Profile

Actions

Bug #19248

closed

ssh Remote Execution fails when output contains special characters

Added by IfAM Admins over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

When using "Run Job" with "Commands" and "Run Command - SSH Default" on CentOS 7.3 with Foreman 13.2 or 14.2 with commands, which produce special character as output, it fails and at least the the following error is displayed:
'Failed to initialize: Dynflow::ExecutionPlan::Steps::Error - Playbook execution failed'

To reproduce, run one ofthe following commands:

systemctl status iptables
echo ●
echo ü

On the other hand the following command is working:

systemctl status iptables | tr -d ●

Maybe, this is not the intended behaviour.


Related issues 1 (0 open1 closed)

Related to Foreman Remote Execution - Bug #18356: Smart proxy worker fails on encoding errorClosedAdam Ruzicka02/01/2017Actions
Actions #1

Updated by Marek Hulán over 6 years ago

I encountered the same. As a simple workaround, add LANG=C to the top of the template. I think it's already reported as #18356

Actions #2

Updated by IfAM Admins over 6 years ago

Marek Hulán wrote:

I encountered the same. As a simple workaround, add LANG=C to the top of the template. I think it's already reported as #18356

Thank you for your quick help, we searched the bug reports, but didn't find it. Your idea works like charm.

Actions #3

Updated by IfAM Admins over 6 years ago

  • Status changed from New to Resolved
Actions #4

Updated by Marek Hulán over 6 years ago

  • Related to Bug #18356: Smart proxy worker fails on encoding error added
Actions

Also available in: Atom PDF