Project

General

Profile

Bug #19311

Data store is selected when datastore cluster is set in compute profile when creating new host

Added by Sander Cornelissen over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When we try to create a new host, which will be image provisioned, then the compute profile is used. In this compute profile we have selected a datastore cluster. But in the new host, the Data store and the Datastore Cluster fields are both activated. When we do a Submit (the POST), we see in de Form Data that both host[compute_attributes][volumes_attributes][0][storage_pod] and
host[compute_attributes][volumes_attributes][0][datastore] are send.

This seems wrong, the datastore should not be send. When we in the form of creating a new host reselect the datastore cluster then Data store is grayed out en not being send when clicking Submit. That is what should happen without reselecting the datastore cluster. It looks like a frontend bug.

We use VMWare as Compute Resource.


Related issues

Is duplicate of Foreman - Bug #25013: VM getting provisioned with the wrong storage.Closed

History

#1 Updated by Dominic Cleal over 4 years ago

  • Category set to Compute resources - VMware

#2 Updated by Ondřej Ezr over 2 years ago

  • Related to Bug #25013: VM getting provisioned with the wrong storage. added

#3 Updated by Ondřej Ezr over 2 years ago

  • Related to deleted (Bug #25013: VM getting provisioned with the wrong storage.)

#4 Updated by Ondřej Ezr over 2 years ago

  • Is duplicate of Bug #25013: VM getting provisioned with the wrong storage. added

#5 Updated by Ondřej Ezr over 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF