Project

General

Profile

Feature #19383

Provide description for Hammer command to disable/enable notifications for a host.

Added by Tomer Brisker over 1 year ago. Updated 2 months ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
API
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1443804

Description of problem:

There is not hammer command to enable/disable notifications
for a particular host.

This feature is available in GUI:
1) Hosts > All Hosts > Tick host >Select Action > Disable Notification
2) Hosts > All Hosts > Tick host >Select Action > Enable Notification

How reproducible:
#hammer host update --help
#hammer host create --help

Actual results:
No option available to enable/disable notifications for a host via hammer cli.

Expected results:
#hammer host update --name <hostname> --notifications <enable/disable>


Related issues

Copied to Hammer CLI - Bug #24490: Provide description for Hammer command to disable/enable notifications for a host.Closed

Associated revisions

Revision 22d605d9 (diff)
Added by Marek Hulán about 1 year ago

Fixes #19383 - document enabled host attribute

History

#1 Updated by Tomer Brisker over 1 year ago

The option exists as --enable, but there is no description for it.

#2 Updated by Tomer Brisker over 1 year ago

  • Description updated (diff)

#3 Updated by Marek Hulán about 1 year ago

  • Project changed from Hammer CLI to Foreman
  • Category changed from Hosts to API
  • Assignee set to Marek Hulán

This seems to be missing documentation in apipie.

#4 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4618 added

#5 Updated by Anonymous about 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Marek Hulán about 1 year ago

  • Legacy Backlogs Release (now unused) set to 240

#7 Updated by Marek Hulán about 2 months ago

  • Copied to Bug #24490: Provide description for Hammer command to disable/enable notifications for a host. added

Also available in: Atom PDF