Project

General

Profile

Bug #19412

kexec fails when Katello is installed and using synced content instead of installation media

Added by Ohad Levy over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Since katello no longer creates an install medium, kexec fails to find the correct url for kernel / initrd.


Related issues

Related to Katello - Bug #16728: stop creating installation media for synced reposClosed2016-09-28
Related to Discovery - Feature #16315: Check kernel/image before attempting to kexecNew

Associated revisions

Revision 5855f4b4 (diff)
Added by Lukas Zapletal over 1 year ago

Fixes #19412,#19732 - kexec path and seed fixed

History

#1 Updated by Ohad Levy over 1 year ago

  • Related to Bug #16728: stop creating installation media for synced repos added

#2 Updated by Lukas Zapletal over 1 year ago

What exactly do you mean by failing? You mean it does not use the overriden URL provided by Katello and returns the associated installation media path instead?

#3 Updated by Lukas Zapletal over 1 year ago

  • Target version set to Discovery Plugin 9.1.0

#4 Updated by Ohad Levy over 1 year ago

Katello does not use install media, hence it is unable to download the kernel/initrd.

steps to reproduce:
1. install foreman + katello
2. sync OS (e.g. centos)
3. try to install via katello content (and not install media).

AFAIR I was able to debug this only using pry, as the exception is eaten by https://github.com/theforeman/foreman_discovery/blob/develop/app/models/host/managed_extensions.rb#L51

#5 Updated by Lukas Zapletal over 1 year ago

  • Related to Feature #16315: Check kernel/image before attempting to kexec added

#6 Updated by Lukas Zapletal over 1 year ago

  • Status changed from New to Rejected

Unable to reproduce, Synced Content cannot be set only in case you dont have installation source set. In nested HG there is a bug when this cannot be set, you cannot inherit IS but this is not bug in discovery. I just tested K3.4 works just fine. I had to apply this patch on the proxy tho:

https://github.com/theforeman/smart-proxy/pull/531/files

#7 Updated by Lukas Zapletal over 1 year ago

  • Status changed from Rejected to New

Oh wait it does not kexec, that's what you mean. It's empty in the request:

{
  "kernel": "",
  "initram": "",
  "append": "ks=http://zzzap.lab.eng.brq.redhat.com:8000/unattended/provision?token=ca9f52fe-cf23-4a6f-b764-b0cefb40b649&static=yes inst.ks.sendmac ip=192.168.220.11::192.168.220.1:255.255.255.0:::none nameserver=192.168.220.1 ksdevice=bootif BOOTIF=00-52-54-00-f5-02-ad nomodeset ",
  "extra": ["--args-linux"]
}

#8 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing
  • Assignee set to Lukas Zapletal
  • Pull request https://github.com/theforeman/foreman_discovery/pull/350 added

#9 Updated by Lukas Zapletal over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF