Project

General

Profile

Bug #19455

1.15.0-RC2 Scanning for puppet classes - Foreman attempts to delete environments that exist

Added by Jack Watroba about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Upgraded to 1.15.0-RC2 on both our foreman server and our puppet smart-proxy server. When we go to import classes from that server, Foreman claims that there are no environments and wants to delete the environments that do exist. It looks like this issue: http://projects.theforeman.org/issues/18995 which looks like it got fixed, but we're still experiencing this behavior.


Related issues

Is duplicate of Foreman - Bug #18995: Puppet class import removes existing environments when orgs/locations are disabledClosed2017-03-23

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Bug #18995: Puppet class import removes existing environments when orgs/locations are disabled added

#2 Updated by Dominic Cleal about 5 years ago

#18995 is unfixed, it's still in New status. I'll mark this as a duplicate until that's resolved, thanks for the report.

#3 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF