Project

General

Profile

Bug #19482

Katello install fails on RHEL7 with /.../kafo/data_type.rb:29:in `register_type': Data type Stdlib::Unixpath is already registered, cannot be re-registered (ArgumentError)

Added by Thorben Jändling over 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

This is a fresh install on RHEL 7.3, no config files were touched. First I followed the Foreman install instructions (https://theforeman.org/manuals/1.14/quickstart_guide.html#QuickstartGuide) and then thereafter the Katello instructions (https://theforeman.org/plugins/katello/3.3/installation/index.html). Resulting in:

# foreman-installer --scenario katello --help
/usr/share/gems/gems/kafo-1.0.5/lib/kafo/data_type.rb:29:in `register_type': Data type Stdlib::Unixpath is already registered, cannot be re-registered (ArgumentError)
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/data_type_parser.rb:22:in `block in register'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/data_type_parser.rb:20:in `each'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/data_type_parser.rb:20:in `register'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:314:in `block (2 levels) in register_data_types'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:313:in `each'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:313:in `block in register_data_types'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:312:in `each'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:312:in `register_data_types'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:91:in `modules'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:193:in `params'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/configuration.rb:203:in `preset_defaults_from_puppet'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/scenario_manager.rb:208:in `load_and_setup_configuration'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/kafo_configure.rb:274:in `set_parameters'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/kafo_configure.rb:99:in `initialize'
        from /usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:133:in `new'
        from /usr/share/gems/gems/clamp-1.0.0/lib/clamp/command.rb:133:in `run'
        from /usr/share/gems/gems/kafo-1.0.5/lib/kafo/kafo_configure.rb:154:in `run'
        from /usr/sbin/foreman-installer:8:in `<main>'

Install steps from .bash_history:

curl -k -O https://yum.puppetlabs.com/puppetlabs-release-pc1-el-7.noarch.rpm
rpm -i puppetlabs-release-pc1-el-7.noarch.rpm
curl -k -O https://yum.theforeman.org/releases/1.14/el7/x86_64/foreman-release.rpm
rpm -i foreman-release.rpm 
yum install foreman-installer
foreman-installer
firewall-cmd --permanent --zone=public --add-port=80/tcp --add-port=443/tcp
firewall-cmd --permanent --zone=public --add-port=8443/tcp --add-port=8140/tcp
firewall-cmd --reload

Checked the foreman web UI and then moved onto Katello:

curl -k -O https://fedorapeople.org/groups/katello/releases/yum/3.3/katello/el7/x86_64/katello-repos-latest.rpm
rpm -i katello-repos-latest.rpm 
yum install katello
foreman-installer --scenario katello --help
(ERROR HERE)
cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)

Related issues

Is duplicate of Katello - Tracker #7605: As a Foreman user, I would like to be able to add Katello later to an existing Foreman installationNeed more information

History

#1 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) changed from 226 to 228

#2 Updated by Justin Sherrill over 4 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 228 to 166

This looks like you installed katello ontop of foreman which is not supported. Katello needs to be installed on a fresh system. See http://projects.theforeman.org/issues/7605 for more information

#3 Updated by Justin Sherrill over 4 years ago

  • Is duplicate of Tracker #7605: As a Foreman user, I would like to be able to add Katello later to an existing Foreman installation added

Also available in: Atom PDF