Project

General

Profile

Refactor #19524

Pin roadie-rails for Ruby < 2.2 compatibility

Added by Dominic Cleal over 1 year ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Packaging
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

roadie-rails 1.2.0 dropped support for Ruby 2.1 and older, and since 1.2.1 has the minimum version explicitly set to 2.2.

Gem::InstallError: roadie-rails requires Ruby version >= 2.2.

The gem should be pinned on older versions.


Related issues

Related to Foreman - Tracker #19577: Drop Ruby 2.1 supportClosed2017-05-17

Related to Foreman - Refactor #21086: Remove pinnings for Ruby 2.1Closed2017-09-24

Associated revisions

Revision 76dd13f7 (diff)
Added by Dominic Cleal over 1 year ago

fixes #19524 - pin roadie-rails to 1.1.x on Ruby 2.0-2.1

Revision 4638096b (diff)
Added by Dominic Cleal about 1 year ago

fixes #19524 - pin roadie-rails to 1.1.x on Ruby 2.0-2.1

Revision d36e456c (diff)
Added by Dominic Cleal about 1 year ago

fixes #19524 - pin roadie-rails to 1.1.x on Ruby 2.0-2.1

History

#1 Updated by The Foreman Bot over 1 year ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4527 added

#2 Updated by Dominic Cleal over 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Ivan Necas over 1 year ago

#4 Updated by Daniel Lobato Garcia about 1 year ago

  • Legacy Backlogs Release (now unused) set to 248

#5 Updated by The Foreman Bot about 1 year ago

  • Pull request https://github.com/theforeman/foreman/pull/4613 added

#6 Updated by The Foreman Bot 11 months ago

  • Pull request https://github.com/theforeman/foreman/pull/4868 added

#7 Updated by Michael Moll 11 months ago

Also available in: Atom PDF