Project

General

Profile

Refactor #19616

Support split-out fog-digitalocean gem

Added by Michael Moll over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
High
Assignee:
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

fog and fog-core got upgraded in #17377, it's now necessary to refactor this plugin to pull in and use the split-out fog-digitalocean gem.


Related issues

Blocked by Foreman - Feature #17377: Update fog-core to 1.43.0Closed2016-11-17

Associated revisions

Revision 9eed06d2 (diff)
Added by Dominic Cleal about 2 years ago

fixes #19616 - use fog-digitalocean gem

Fog 1.40.0 (as used in Foreman 1.16+) has extracted the DO provider into
the fog-digitalocean gem, renaming the classes to remove the version
number. This is incompatible with older Fog and Foreman releases.

Also renames the Fog extensions to match Rails autoloader standards.

History

#1 Updated by Michael Moll over 2 years ago

#2 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Dominic Cleal
  • Pull request https://github.com/theforeman/foreman-digitalocean/pull/17 added

#3 Updated by Dominic Cleal about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF